Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
15773 Discussions

CTRL+L not working correctly - Quartus Prime 21.1.0 Build 842 Lite Edition

Carlhermann
New Contributor I
247 Views

Hi, 

I installed above referenced version and unfortunately the well known "CTRL+L" shortcut to start compilation now ends in deletion of current line within the code rather starting compilation. CTRL+K is still ok, CTRL+L is working fine in Quartus 20.1 edition (thus I'd exclude - if at all possible - issues with the OS (Win 11 Pro). 

Is this a known issue (with a fix)? 
I'm kind of shortcut user rather always moving the cursor to click on buttons

Thanks a lot  

0 Kudos
4 Replies
sstrell
Honored Contributor III
236 Views

Ctrl-L works fine for me.  Windows 11 is not supported for Quartus officially, but I doubt at this level there would be this type of issue with it.  Maybe your window focus is incorrect when you're pressing the shortcut since you say it is affecting the text editor instead of compiling the design.

Carlhermann
New Contributor I
230 Views

Hi, 
I do as I did with earlier versions... After editing the VHDL file (with Quartus' internal text editor), I just wanted to start compilation by "CTRL+L". 

Now (for syntax check) I use CTRL+K, which works...

Ok - just tried to start compilation with current window in the Quartus Software not being a source code file, but the compilation report. This worked, most likely as the report is not opened by the internal text editor?

 

 

Carlhermann
New Contributor I
219 Views

Further update

I "googled" the shortcut and CTRL+L is used in Visual Studio (I do have that installed as well) to cut the current line and copy it to the clipboard. This seems to happen, as starting a simple editor, this line can be pasted by CTRL+V... 

Don't know if this is the root cause (and if it would be, it wouldn't help as I need Visual Studio as well)

finally it looks like an issue with the text editor itself - with e.g. using CTRL+F (thus the cursor is in the "find" window), CTRL+L starts compilation. 

Well - will most likely end with "win 11 is not supported yet, use on own risk" I assume

 

 

SyafieqS
Moderator
215 Views

Hi Carlhermann,


Yes, true Win 11 is not officially support for Quartus yet and you are encourage to use OS supported.

Otherwise have yo use at your own risk.




Reply