Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
16685 Discussions

Can't download Quartus software - links broken?

BrianT
Beginner
2,123 Views

Hi,

I can't seem to download any of the Quartrus prime software installs. I've tried with 3 different browsers (Edge, Chrome & FireFox) and nothing works when trying to download. On the most recent versions, when clicking download link nothing happens. On older versions, the "Legal Disclaimer" pops-up, but then nothing happens afterwards.

 

I've read in earlier discussions that the Java Scripts are not correct or broken. Are they broken again?

0 Kudos
11 Replies
SyafieqS
Employee
2,106 Views

Hi Brian,


What type of Quartus version you want to download? I can get a direct link as an alternative for you


0 Kudos
BrianT
Beginner
2,100 Views

Initially I was trying to download 20.1 Lite version, which via Reddit info I was able to do. This however, then failed because that package has an expired USB Blaster driver. The certificate will not allow it to be installed on Windows 10 and my company will not allow unsigned drivers to be installed so that is a NO GO.

What I need is a valid USB-Blaster driver (NOT USB-Blaster II) but there is no way to get just that without installing the entire Quartus.

So now my only hope is to try 21.1 Pro, but every download link has the same Java Script flaw. The problem appears to be in common.js and the line wap_tms.custom.trackDownload(data);. Why can't this be fixed?

 

 

0 Kudos
sstrell
Honored Contributor III
2,088 Views
0 Kudos
BrianT
Beginner
2,081 Views

I still don't see it. The one that is "download cable" not "download cable II" just provides instructions to load the driver from the install location of the Quartus software, which is my case would point to drivers that have expired certificates and can't be installed.

 

The one at the very top seem to only be a firmware update of the actual USB Blaster pod and does not appear to contain any drivers for Windows 10.

 

Which one would contain the actual Windows 10 driver, for USB Blaster, not USB Blaster II?

 

At the top of that page that you've pointed me to is this statement:

"Note: Some cable drivers are not available for download on this page. They are available after you install the Intel Quartus Prime software in the <Quartus Prime Installation Directory>\drivers directory."

 

0 Kudos
SyafieqS
Employee
2,067 Views

Hi Brian,


Below is link for direct download alternative link for Lite 20.1 Window

https://download.altera.com/akdlm/software/acdsinst/20.1std/711/ib_tar/Quartus-lite-20.1.0.711-windows.tar


0 Kudos
BrianT
Beginner
2,060 Views

Does that link still contain expired Windows 10 drivers thus making it not useful or has the download package been fixed and have updated drivers been packaged?

0 Kudos
SyafieqS
Employee
2,006 Views

Hi Brian,


By default all the Quartus download should contain driver or managed by OS itself for example win 10. Are you able to download via the link given? Any update?


0 Kudos
BrianT
Beginner
1,990 Views

SyafieqS,

 

You don't seem to be reading everything. The original issue was the inability to download due to Java script issues with the website. I suspect these issue still exist. This was resolved by members in the Reddit community, not by anyone at Intel, as they described how to work around it.  

 

After downloading the Lite version I could not install the USB Blaster drivers as they are expired. Note I only need the Lite version because I am not the FPGA designer and I just need to load the FPGA using the USB Blaster. Windows 10 does not let you install expired drivers and my IT department also won't allow that. Expired drivers are packaged with the Lite version. You then said I should go download the drivers from another location without actually checking to see if the drivers were actually there. The drivers for the USB Blaster are not there, just a document saying you need to install the Quartus package to get them. DO YOU SEE THE PROBLEM????????

 

You need to repackage the Lite version with new drivers. Why is this so hard to understand??????

 

The level of support after Intel took over Altera is very disappointing.  

0 Kudos
SyafieqS
Employee
1,946 Views

Readdressing to your question, the direct link given, the download package should be fixed and updated the driver. Thus should not been any issue. Direct link given to you as alternative as I already reported the downloading issue for JS flaw. By now the issue should be fixed.


0 Kudos
mfaircloth
Beginner
1,801 Views

It is now 9/15/2021 and the JavaScript issue has not been fixed.

0 Kudos
Frank1stein
Beginner
1,703 Views

I am having the same problem in both Crome and Edge on Windows. I want to download the Cyclone 10 LP device support package for Quartus 20.1.1 - but nothing happens after I accept the disclaimer. Seems like some javascript problem. Downloading the 1.6GB full update is not an option on my current link, so it would be nice of the download for older components could be fixed.

 

Seems to be a problem with a tracking cookie, I see this error in the console:

common.js:36

Uncaught TypeError: Cannot read properties of undefined (reading 'trackDownload')
at recordOutboundLink (common.js:36)
at Object.success (common.js:179)
at c (jquery-3.6.0.min.js:2)
at Object.fireWith [as resolveWith] (jquery-3.6.0.min.js:2)
at l (jquery-3.6.0.min.js:2)
at XMLHttpRequest.<anonymous> (jquery-3.6.0.min.js:2)

 

And as suggested in a Reddit thread, uncommenting line 36 in common.js allows the file to be downloaded. ( Editing javascrip in the browser )

0 Kudos
Reply