Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
16728 Discussions

Can't launch the Modelsim-Altera Software

Altera_Forum
Honored Contributor II
80,845 Views

Hi, 

 

My OS is Windows 8 64 bit. I'm using Quartus II 13.1 Web Edition, and Modelsim 10.1d. 

 

My path in EDA Tools is set to "C:\altera\13.1\modelsim_ase\win32aloem", when I go Tools > Run Similation Tool > RTL Simulation; I get this Nativelink Error: 

 

Can't launch the ModelSim-Altera software -- the path to the location of the executables for the ModelSim-Altera software were not specified or the executables were not found at specified path... 

 

I can manually start it by the way. 

 

Thank you 

Baris Yakut
0 Kudos
27 Replies
Altera_Forum
Honored Contributor II
56,190 Views

You need to specify the link to the ModelSim executable file in the Quartus Option before launching nativelink. Or check your environment variable to see if it is pointing to the right file.

0 Kudos
Altera_Forum
Honored Contributor II
56,190 Views

Can you be more specific? How can I do things that you mentioned?

0 Kudos
Altera_Forum
Honored Contributor II
56,190 Views

I just tried launching the RTL Simulation Tool and got the same error. I checked Tools>Options>EDA Tool Options and noticed that the path to the ModelSim executable was wrong - it hadn't been updated from 13.0 when I updated to 13.1. I changed 13.0 to 13.1 and the simulation tool worked OK. It now reads "C:\altera\13.1\modelsim_ase\win32aloem".

Altera_Forum
Honored Contributor II
56,197 Views

Hi there, 

 

I have same problem as vitruvius but in windows 7 64. 

 

It's a clean install. 

 

Quartus II 13.1 Web Edition 

Modelsim 10.1d.
0 Kudos
Altera_Forum
Honored Contributor II
56,197 Views

It works!!!!!! 

 

when you add the path: 

 

"C:\altera\13.1\modelsim_ase\win32aloem" you need to add "\" 

 

result: 

 

"C:\altera\13.1\modelsim_ase\win32aloem\

 

and it works!!!!
michael30
Beginner
13,270 Views
0 Kudos
brenomax
Beginner
12,559 Views
0 Kudos
Altera_Forum
Honored Contributor II
56,197 Views

 

--- Quote Start ---  

It works!!!!!! 

 

when you add the path: 

 

"C:\altera\13.1\modelsim_ase\win32aloem" you need to add "\" 

 

result: 

 

"C:\altera\13.1\modelsim_ase\win32aloem\

 

and it works!!!! 

--- Quote End ---  

 

 

Thanks man. It works now.
0 Kudos
Altera_Forum
Honored Contributor II
56,197 Views

thanks 

my problem soleved too
0 Kudos
Altera_Forum
Honored Contributor II
56,197 Views

 

--- Quote Start ---  

It works!!!!!! 

 

when you add the path: 

 

"C:\altera\13.1\modelsim_ase\win32aloem" you need to add "\" 

 

result: 

 

"C:\altera\13.1\modelsim_ase\win32aloem\

 

and it works!!!! 

--- Quote End ---  

 

 

Thanks, this is great. I cannot enter a smiley here, not sure why. Oh, well.
0 Kudos
Altera_Forum
Honored Contributor II
56,197 Views

 

--- Quote Start ---  

It works!!!!!! 

 

when you add the path: 

 

"C:\altera\13.1\modelsim_ase\win32aloem" you need to add "\" 

 

result: 

 

"C:\altera\13.1\modelsim_ase\win32aloem\

 

and it works!!!! 

--- Quote End ---  

 

 

Thank you!
0 Kudos
Altera_Forum
Honored Contributor II
56,197 Views

 

--- Quote Start ---  

 

when you add the path: 

 

"C:\altera\13.1\modelsim_ase\win32aloem" you need to add "\" 

 

--- Quote End ---  

 

 

This also worked for me, using Quartus II 13.1 Update 4 newly installed on Windows 7 64-bit. 

 

Thanks!
0 Kudos
Altera_Forum
Honored Contributor II
56,197 Views

+1 on this- Tried it and it works

0 Kudos
Altera_Forum
Honored Contributor II
56,197 Views

Thanks, it works!

0 Kudos
Altera_Forum
Honored Contributor II
56,197 Views

This should be reported as a bug.

0 Kudos
Altera_Forum
Honored Contributor II
56,194 Views

OH; 

I hade the same proplem and I add "\" and it was fixed. 

Thanks;
0 Kudos
Altera_Forum
Honored Contributor II
56,194 Views

Hi! I also had this problem, and in my case the solution of adding the '\' was not enough. I had one more configuration issue, and thought I'll post my problem/solution here for you. 

 

I am running Quartus II 16.0 and ModelSIM Altera Starter 10.4d and had all paths set right. What helped was to also set the correct EDA tool in the project settings. To verify, go to Assignments > Settings > EDA Tool Settings and make sure you have ModelSIM-Altera selected under Tool Name. Similarly, go to Assignments > Settings > EDA Tool Settings > Simulation and do the same. Initially I had it set to ModelSIM, and Quartus was right to not find the right executables.
Claudius_Maximus
Beginner
17,029 Views

Thank you very much for this!!  My headache was immediately resolved after finding this!

0 Kudos
Altera_Forum
Honored Contributor II
56,194 Views

 

--- Quote Start ---  

It works!!!!!! 

 

when you add the path: 

 

"C:\altera\13.1\modelsim_ase\win32aloem" you need to add "\" 

 

result: 

 

"C:\altera\13.1\modelsim_ase\win32aloem\

 

and it works!!!! 

--- Quote End ---  

 

 

I had this same problem and this solution worked!!! Thanks a lot!!
0 Kudos
Altera_Forum
Honored Contributor II
56,194 Views

OK, this is a link to the licensed Modelsim-Altera. But what's the path to the ModelSim starter Edition?

0 Kudos
Reply