Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
15469 Discussions

Can't open the Stratix 10 Board Test System with Quartus 19.2

SDe_J
Novice
457 Views

I am developing firmware with the Stratix 10 H-tile devkit.

 

I have downloaded the support files located here:

https://www.intel.com/content/www/us/en/programmable/products/boards_and_kits/dev-kits/altera/kit-s1...

 

I have Quartus 19.2 installed on my (linux: Ubuntu 16.04) system

 

I'm trying to open the board test system included with the support files, but I'm getting this error:

>echo $QUARTUS_ROOTDIR /intelFPGA/19.2/quartus   >./BoardTestSystem.sh ./BoardTestSystem.sh: 2: [: /intelFPGA/19.2/quartus: unexpected operator Error: Could not find or load main class com.intel.bts.BtsApp

I have been able to run the BTS with quartus 18.0 and 18.1, but not 19.2. Do you know what the issue might be?

 

Thank you.

 

 

 

 

0 Kudos
2 Replies
SDe_J
Novice
327 Views

If I try to run it manually, I get the same error:

>/intelFPGA/19.2/quartus/linux64/jre64/bin/java -Xmx256m -jar bts.jar Error: Could not find or load main class com.intel.bts.BtsApp

 

AR_A_Intel
Employee
327 Views

Hello,

 

Welcome to INTEL forum. Based on my understanding, possibly it is caused by the difference in system console of different Quartus revisions. The BTS module for Stratix 10 FPGA H-Tile is build based on Quartus® Prime v17.1 and  v18.1. It is suggested to use the right Quartus version with the right dev.kit version.

 

Reply