Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
15546 Discussions

DE10-Nano GHRD failure to generate

Altera_Forum
Honored Contributor II
950 Views

Hi All 

 

I'm trying to recompile the standard GHRD for the Terasic De10-Nano Cyclone V SoC Board, and following the instructions (User Manual chapter 7) very carefully, it fails with a great number of errors (and four warnings), the first one a complaint about a missing file hps_AC_ROM.hex. This file does exist, in the soc_system/synthesis/submodules/ directory. 

 

Has anyone met this? Or can give any useful pointer for what to try? 

 

The source is from Terasic's DE10-Nano CD-ROM v 1.2.3 (but the versions of this CD do the same thing). 

 

To repeat the error: 

 

  1. Make a copy of the source: cp -Rp cdrom/Demonstrations/SoC_FPGA/DE10_NANO_SoC_GHRD GHRDx  

  2. cd GHRDx  

  3. Run quartus  

  4. open project DE10_NANO_SoC_GHRD.qpf  

  5. Tools > qsys and open soc_system.qsys  

  6. generate > generate hdl, (defaults for form: Verilog, no third-party, yes create block, sim model none, output dir ./soc_system)  

 

 

 

The generate hdl command fails with errors, the first of which isError: border: Error during execution of script generate_hps_sdram.tcl: seq: add_fileset_file: No such file /tmp/alt7540_4530398708016069914.dir/0003_seq_gen/hps_AC_ROM.hex 

 

 

The compilation environment is a newly-configured Ubuntu 16.04 LTS server with$ quartus_sh --version 

Quartus Prime Shell 

Version 16.0.0 Build 211 04/27/2016 SJ Lite Edition 

 

 

I tried it with 17.0 and got the same result: but 16.0 is what the manual says you need, and is what the source was made with. 

 

I've managed to compile the simpler, non-Qsys examples and run them, but I've spent about five days getting nowhere with this. 

 

Many thanks for any help and suggestions, 

Jonathan.
0 Kudos
1 Reply
Altera_Forum
Honored Contributor II
151 Views

I managed to solve it ... 

 

Guessing a missing dependency of some kind, strace and fgrep ENOENT eventually gave the clues. 

 

Quartus requires "make", but they don't tell you in the documentation. 

 

There is also a bug, in that Quartus continues after failing to find "make", or if make returns non-zero exit status. Bug reports filed with Altera, we shall see how they respond. 

 

In the example, the calling process which expected to find hps_AC_ROM.hex makes a spurious error. 

(Make was supposed to get it from ./soc_system/synthesis/submodules/hps_AC_ROM.hex) 

 

The fix is trivial 

sudo apt-get install make  

 

The bug exists in 16.0, 16.1, 17.0, 17.1 and I'd guess all previous. 

 

Oh for shame! 

 

In solving this I made installation scripts, happy to share if there's any demand. 

 

Jonathan.
Reply