Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
1,012 Views

Does Quartus (13.1) synthesizer supports configurations ?

Hi, 

 

The question is in the title.  

My impression is that the answer is "no", but i would like to have a confirmation. 

 

In file mul.vhd, i have one entity (mul8) and two architectures (rtl1 and rtl2). 

Whatever i write in the top level file ... 

* direct architecture selection : M:entity work.mul(rtl1) port map(..); 

* single line configuration : for M: mul8 use entity work.mul8(rtl1); 

* distinct, top-level configuration unit : configuration top_conf of top is for arch for T: mul8 use entity work.mul8(rtl1); 

end for;end for; end configuration; 

.. the synthesizer systematically uses the last architecture defined in mul.vhd (rtl2 in my case) :( 

 

Any help or clue appreciated 

 

JS
0 Kudos
2 Replies
Altera_Forum
Honored Contributor I
34 Views

Have you tried separating the two architectures into two files? 

Configurations are not something you see people use very often. Usually people make entities with generics and use generics/generates to control what actually goes into the modules. 

But configurations should work, although I note this issue from 2012: 

https://www.altera.com/support/support-resources/knowledge-base/solutions/rd07032012_70.html 

 

Configurations have been around a long time, so should work. But alas - I never use them, so cannot test for you. 

Have you tried a newer version?
Altera_Forum
Honored Contributor I
34 Views

No, did not try. Will do it (although this approach, in my particular case, is not really appropriate since my goal is to keep several "small" architectures in the same file). 

I have already read the provided link. Not clear, however, if this applies to single level configuration (apparently, yes :(). 

Another approach would be to try a newer version. I've tried to install Quartus 16 but it's too big for my VM system :( 

Thx for your feedback anyway. Will report if i find a solution.
Reply