Community
cancel
Showing results for 
Search instead for 
Did you mean: 
GFREY1
Beginner
1,260 Views

Doesn't Quartus Prime Pro support SCFIFO and DCFIFO for Cyclone 10?

Jump to solution

I installed Cyclone 10 GX device support in Quartus Prime Pro 17.0.  I'm not seeing the FIFO option under On-Chip Memory in the IP Catalog.  This option is documented even in the latest FIFO Intel FPGA IP User Guide.  I clicked on the Add button under the Catalog, which opened up Qsys, but the only FIFOs it showed were various Avalon FIFOs.  I'm upgrading a design from an older Cyclone version which used the Altera standard SCFIFO and DCFIFO, so I'd rather not have to change them to another FIFO type.  Thanks in advance for any advice.

0 Kudos
1 Solution
Abe
Valued Contributor II
86 Views

I checked with the Quartus Prime 18 version, and since the Cyclone10GX device is free, it does support the FIFO IP. I can see this IP present in the IP Catalogue. Check your license file setup for the tool and make sure its valid.

 

Check the screenshot I've uploaded. Its the Pro v18 tool and Cyclone10GX device and you can see the FIFO IP on the right pane. I can even customize it and select the SCFIFO or DCFIFO type.

 

If nothing else works, I suggest you upgrade the tools to the latest 18 version and check.

View solution in original post

2 Replies
AnandRaj_S_Intel
Employee
86 Views

Hi,

 

  1. You can use "Avalon FIFO Memory" from QSYS IP Catalog and from parameters Tab ->Basic settings -> clock setting->you can selects either SCFIFO and DCFIFO.
  2. Yes, You can perform auto update.

fifo.png

Let me know if this has helped resolve the issue you are facing or if you need any further assistance.

 

Best Regards,

Anand Raj Shankar

(This message was posted on behalf of Intel Corporation)

Abe
Valued Contributor II
87 Views

I checked with the Quartus Prime 18 version, and since the Cyclone10GX device is free, it does support the FIFO IP. I can see this IP present in the IP Catalogue. Check your license file setup for the tool and make sure its valid.

 

Check the screenshot I've uploaded. Its the Pro v18 tool and Cyclone10GX device and you can see the FIFO IP on the right pane. I can even customize it and select the SCFIFO or DCFIFO type.

 

If nothing else works, I suggest you upgrade the tools to the latest 18 version and check.

View solution in original post

Reply