Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.

EMAC options for Arria 10

gcohe5
Novice
456 Views

hi

I'm trying to implement 2 out of 3 Ethernet ports on Arria 10 Kit (using Quartus prime pro 18.1).

On the platform designer IP editor for the HPS IP (altera_arria10_hps) I get the following options (under: Pin Mux ans Peripherals>IP Selection) - see attached capture below, ip_1:

EMAC A: (if/phy)

EMAC B: (if/phy)

EMAC C: (if/phy)

 

and under: Pin Mux ans Peripherals > Advanced FPGA Placement - see attached capture below, ip_2:

EMAC 0 Interface: (if/PHY)

EMAC 1 Interface: (if/PHY)

EMAC 2 Interface: (if/PHY)

 

what is the difference between these two option settings?

 

thanks

 

 

0 Kudos
5 Replies
Fawaz_J_Intel
Employee
229 Views

Hello,

I will look into this issue and let you know the feedback soon,

 

thank you

Fawaz_J_Intel
Employee
229 Views

Hello,

My apologize for the late reply. We were working on few debugging steps to make sure there is no bug in this GUI, however, there might be a bug where the two options menu are not reflecting each other. This is not confirmed yet.

 

IP selection settings can be seen on Advanced FPGA settings tab, however, the reverse direction cannot be seen reflected. And here is the bug possibility.

You can refer to the IP selection configurations. Once you are done, press the Apply Selection button.

 

Thank you

gcohe5
Novice
229 Views

hi,

thank you.

 

does this update the "advance pin placement" with the proper pins as well?

 

 

Fawaz_J_Intel
Employee
229 Views

Hello,

Yes, it will update the pins.

I will let you know once I get a feedback on the GUI issue.

 

Thank you.

 

gcohe5
Novice
229 Views

hi

what seems to work without messing up the pin placement is:

  1. updating "advanced pin placement" and "advanced FPGA placement" and pressing 'apply'
  2. changing the "ip selection" to fit the above changes but **not** pressing apply
  3. save , generate etc.
Reply