Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
Announcements
All support for Intel NUC 7 - 13 systems has transitioned to ASUS. Read latest update.

Error when programming Agilex

gquinet
Beginner
2,303 Views

Hello everybody,
I’m am trying to program an Agilex™ F-Series board with my design in Quartus 21.3, but i get the following error:
Error (18950): Device has stopped receiving configuration data
Error (18948): Error message received from device: External hardware access error. (Subcode 0x0032, Info 0x00800008, Location 0x00001800)
Error (22248): Detected a PMBUS error during configuration. Potential errors: VID setting is incorrect in the Intel Quartus Prime project. The target device fails to communicate to a smart regulator or PMBUS master on a board.
Error (209012): Operation failed
Info (209061): Ended Programmer operation at Wed Jan 5 10:18:29 2022
Error: Quartus Prime Programmer was unsuccessful. 4 errors, 0 warnings
Error: Peak virtual memory: 3302 megabytes
Error: Processing ended: Wed Jan 5 10:18:29 2022
Error: Elapsed time: 00:01:09
Error: System process ID: 29607

Apparently i need to change the VID setting but i don’t know what to do.

Thanks in advance for your help!

0 Kudos
11 Replies
YuanLi_S_Intel
Employee
2,261 Views

Yes, you need to set the VID setting appropriately.


You may find the user guide at link below:

https://www.intel.com/content/dam/www/programmable/us/en/pdfs/literature/hb/agilex/ug-ag-pwr.pdf#page=47



0 Kudos
gquinet
Beginner
2,206 Views

Thank you for your reply, 

I verified the VID setting but it seems to be correct.

This message appears also when i try to program the Agilex GHRD .sof file.

Is there another way to correct this error?
0 Kudos
YuanLi_S_Intel
Employee
2,188 Views
0 Kudos
gquinet
Beginner
2,180 Views

Thank you for your response, 

I am using this development kit more precisely:

https://www.intel.com/content/www/us/en/products/details/fpga/development-kits/agilex/f-series-transceiver.html

Here are my VID settings:

gquinet_1-1642589059943.pnggquinet_0-1642588958996.png

 

0 Kudos
YuanLi_S_Intel
Employee
2,162 Views

Can you try the following VID setting for Agilex F-Series Development Kit?


set_global_assignment -name VID_OPERATION_MODE "PMBUS MASTER"

set_global_assignment -name USE_PWRMGT_SCL SDM_IO0

set_global_assignment -name USE_PWRMGT_SDA SDM_IO12

set_global_assignment -name USE_CONF_DONE SDM_IO16

set_global_assignment -name PWRMGT_BUS_SPEED_MODE "400 KHZ"

set_global_assignment -name PWRMGT_SLAVE_DEVICE_TYPE OTHER

set_global_assignment -name PWRMGT_SLAVE_DEVICE0_ADDRESS 42

set_global_assignment -name PWRMGT_SLAVE_DEVICE1_ADDRESS 43

set_global_assignment -name PWRMGT_SLAVE_DEVICE2_ADDRESS 44

set_global_assignment -name PWRMGT_SLAVE_DEVICE3_ADDRESS 00

set_global_assignment -name PWRMGT_SLAVE_DEVICE4_ADDRESS 00

set_global_assignment -name PWRMGT_SLAVE_DEVICE5_ADDRESS 00

set_global_assignment -name PWRMGT_SLAVE_DEVICE6_ADDRESS 00

set_global_assignment -name PWRMGT_SLAVE_DEVICE7_ADDRESS 00

set_global_assignment -name PWRMGT_TRANSLATED_VOLTAGE_VALUE_UNIT VOLTS

set_global_assignment -name PWRMGT_VOLTAGE_OUTPUT_FORMAT "AUTO DISCOVERY"

set_global_assignment -name PWRMGT_PAGE_COMMAND_ENABLE ON


0 Kudos
gquinet
Beginner
2,153 Views

Thank you for your suggestion, but i already have these settings for my project

0 Kudos
YuanLi_S_Intel
Employee
2,138 Views

Is the setting works for you? i have tested the setting, no issue on my agilex f-series development kit. If still got issue on your side, you might need to test with simple design.


0 Kudos
gquinet
Beginner
2,126 Views

It's still not working for me, could you tell me your board switches configuration ?

0 Kudos
YuanLi_S_Intel
Employee
2,116 Views

everything is in default position


0 Kudos
YuanLi_S_Intel
Employee
2,061 Views

We do not receive any response from you to the previous answer that I have provided. This thread will be transitioned to community support. If you have a new question, feel free to open a new thread to get the support from Intel experts. Otherwise, the community users will continue to help you on this thread. Thank you


0 Kudos
zhenyu1
Employee
2,018 Views

hi, YuanLi_S_Intel  I met the same issue when i program Agilex-F serial card. I'm intel employee. how can i contact you ? my email is zhenyu1.liu@intel.com

0 Kudos
Reply