Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
15332 Discussions

How do you change the default version of Quartus that opens files?

JFree1
Novice
1,128 Views

My company uses Quartus versions 17.1, 16.0, and 13.0sp1. My question is, how do you get Quartus related files, chiefly .QPFs, to launch by default with version 17.1? I have tried removing the default program in windows for certain file extensions and re-associating it with the 17.1 Quartus.exe, and also opening 17.1 first then clicking the files I want to open, but the default still ends up being 13.0sp1. The only way I can get those files to open with 17.1 is by using the file explorer within that version of the program.

The newest related question to this matter is found in this thread: https://forums.intel.com/s/question/0D50P00003yyQojSAE/setting-default-version-of-quartus-ii-in-wind...

But it did not solve my issue.

I'm running this on Windows 10.

1 Solution
JFree1
Novice
255 Views

I did try that, and the root directory was already pointed in the correct place. However, I got it to work by temporarily removing the quartus.exe for version 13.0sp1 from it's respective file folder, then launching a QPF and picking the correct association to 17.1 at the windows prompt. Why this wouldn't work through the windows default programs manager is beyond me, but it works now.

View solution in original post

2 Replies
Vicky1
Employee
255 Views

Hi,

Have you tried with Cygwin shell terminal?

Was it pointed to respective installer?

 

Best Regards

Vikas Jathar 

(This message was posted on behalf of Intel Corporation)

 

JFree1
Novice
256 Views

I did try that, and the root directory was already pointed in the correct place. However, I got it to work by temporarily removing the quartus.exe for version 13.0sp1 from it's respective file folder, then launching a QPF and picking the correct association to 17.1 at the windows prompt. Why this wouldn't work through the windows default programs manager is beyond me, but it works now.

Reply