Community
cancel
Showing results for 
Search instead for 
Did you mean: 
SSchw11
Beginner
223 Views

How to find the parameter check box called "Provide separate interface for each channel" in the "Transceiver Native PHY Intel Arria 10" IP core?

I am using Quartus Pro 19.3 and the "Transceiver Native PHY Intel Arria 10" IP core. According to the documentation there should be a parameter check box called "Provide separate interface for each channel". But I cannot see any such check box in the Transceiver IP opened in Platform Designer. Is there anything needed to be enabled/disabled to allow that checkbox to appear?

0 Kudos
6 Replies
sstrell
Honored Contributor II
51 Views

Just to make sure, have you set the number of channels to a value greater than 1?

 

#iwork4intel

Deshi_Intel
Moderator
51 Views

HI,

 

Steve has a point.

 

once you set the transceiver channel number > 1, then the "provide separate interface for each channel" option will pop up under "Datapath Options" section where user typically configure the data rate.

 

Thanks.

 

Regards,

dlim

SSchw11
Beginner
51 Views

Thank you for your replies

 

I have the transceiver channel number on 8 and I still can not see the "provide separate interface for each channel" in my Red Hat 6.1 installation.

So I tried it on a Windows installation and there the checkbox appears.

Does any one know how to make it work on Red Hat? Red Hat should be supported by Quartus.

 

Thanks

 

Best Regards

SSchw

Deshi_Intel
Moderator
51 Views

Hi,

 

I am using Red Hat and I am able to see the checkbox.

 

You can try regenerate your NativePHY IP again or create a new Quartus Project again to see if it helps.

 

Thanks.

 

Regards,

dlim

SSchw11
Beginner
51 Views

Hi dlim

 

in a new design and now also in my current design it gives me the checkbox, as soon as I choose the "Standalone" interface view. It disappears when the "System" interface view is selected.

Thank you for your help.

 

Best Regards

SSchw

Deshi_Intel
Moderator
51 Views

HI SSchw,

 

It's great you figure out the issue.

 

Thanks for the sharing as well

 

Regards,

dlim

Reply