Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
15477 Discussions

How to manually set pre-emphasis parameters in qsf file for Stratix 10 transceivers?

JLi38
Beginner
437 Views

I have a Low Latency 100G Ethernet IP in my design and I would like to manually set VOA, pre-tap, and post-tap for the 4 TX lanes. However Quartus 19.1 gave me error.

The settings I used in the project qsf files are

What is the correct way to do it?

Thanks.

0 Kudos
1 Reply
CheePin_C_Intel
Employee
124 Views
Hi Jun Li, As I understand it, you observe some problem when trying to assign the PMA analog settings for the S10 XVCRs. By merely looking at the error messages, it might be due to the specific combination that you are using are not valid. Just would like to check with you which device ie L-tile or H-Tile or E-tile are you using? If you are using L/H-Tile devices, you may try with the Intel Stratix 10 L-Tile/H-Tile Pre-emphasis and Output Swing Estimator (https://www.intel.com/content/www/us/en/programmable/literature/hb/stratix-10/stratix10_htile_pre_em...) to check on the valid combination for pre-emphasis and VOD. Please let me know if there is any concern. Thank you. Best regards, Chee Pin
Reply