Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
15317 Discussions

How to solve the errors below in Simulation Waveform Editor?

JChai1
Beginner
1,861 Views
0 Kudos
11 Replies
Abe
Valued Contributor II
208 Views

You have to also include the following libraries in the vsim command

 

vsim -L cycloneiv_hssi -L cycloneiv_hssi_ver -L cycloneiv_pcie_hip -L cycloneiv_pcie_hip_ver - work.....

 

This will include all of the required device and IP libraries needed for simulation.

Kenny_Tan
Moderator
208 Views

Are you using Altera Modelsim? Only Altera Modelsim come with pre​defined library.

Otherwise you will have to compile the libraries.

Kenny_Tan
Moderator
208 Views

Not sure if you still need help on this?

JChai1
Beginner
208 Views

​Yes, I am using Altera Modelsim.

I have added "-L cycloneiv_hssi -L cycloneiv_hssi_ver -L cycloneiv_pcie_hip -L cycloneiv_pcie_hip_ver" to vsim command:

But once I run the functional simulation in Simulation Waveform Editor, it will overwrite the 'do' file because this file is generated by Simulation Waveform Editor itself:

There is not setting tab in the Simulation Waveform Editor (open from Quartus Prime 15.1).

What can I do so that vsim command cannot be overwritten?

 

 

 

 

 

 

 

 

 

 

 

JChai1
Beginner
208 Views

chassis_fpga_do_before.PNGgenerated_do.PNGchassis_fpga_do_after.PNG

Abe
Valued Contributor II
208 Views

You need to edit the file from within the Waveform editor in Quartus. When you create the input waveforms for the design using the Simulation Waveform Editor, you have to do the following:

 

  1. After creating the waveform, Save the file and either rename it or leave the name as it is (Waveform.vwf).
  2. From the menu, click Simulation -> Simulation Settings.
  3. In the window that pops-up you have to modify the vwf name (if you have changed the name while saving it) in the "Testbench Generator Command" box. Scroll left and change all instances of the "Waveform.vfw" to the name you have specified earlier while saving it. You can also change the name of the generated .vwf.vt file.
  4. Under the Modelsim Script box make change the testbench name (*.vwf.vt) .
  5. In the next line you will see the vsim command. Here include the libraries mentioned earlier. "-L cycloneiv_hssi -L cycloneiv_hssi_ver -L cycloneiv_pcie_hip -L cycloneiv_pcie_hip_ver
  6. Click Save.
  7. Now, generate the testbench and the ModelSim simulation scripts.
  8. Now, everytime you simulate the design, it should include the necessary libs and compile/simulate.

 

VWF.jpg

JChai1
Beginner
208 Views

​But I don't see any "setting" under simulation:

Simulation_setting.png

Abe
Valued Contributor II
208 Views

You have to open the Waveform that you created in the Waveform Editor. In this screen the Simulation Settings option will be there under the Simulation menu item.

Which version of Quatus are you using 18.0 / 18.1 Lite/Std?

 

SimulationSettings.jpg

JChai1
Beginner
208 Views

​I am not seeing the simulation setting under simulation option.

I am using Quartus Prime Version 15.1.0 Build 185 10/21/2015 SJ Standard Edition.

Abe
Valued Contributor II
208 Views

This is present in the later versions.. 18 and 18.1 , am not sure about 15. Why don't you try upgrading to the latest 18.1 Lite version ? It would solve this issue.

JChai1
Beginner
208 Views

​okay, thanks.

Reply