Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
15317 Discussions

JTAG error (Unexpected error in JTAG server -- error code 35 and Can't access JTAG chain)

AAAAAAAAAA
Beginner
1,096 Views

I have to program a 10M04SCE144C8G FPGA that was already programmed (I have to update the program). For this I got a new computer and installed Ubuntu 20.04, after this I downloaded Intel Quartus Prime Lite 20.1.1 and installed it successfully. I also received a brand new Terasic USB Blaster. After connecting everything and compiling my code with no errors I tried to download it to the FPGA with no success. I have no previous experience with Intel FPGAs, Quartus or the Terasic USB Blaster.

When I open the programmer to download the ".pof" file and hit "start" I get this error:

Error (209053): Unexpected error in JTAG server -- error code 35

Screenshot_2021-03-26_16-02-23.png

After googling for a while I arrived to this link and in FAQ #6 they show exactly my problem. So I tried, as is suggested there, to upload the ".sof" file instead. This time I got a different error

202940 Can't access JTAG chain

Screenshot_2021-03-26_16-03-55.png

Any idea on how to make this work?

0 Kudos
6 Replies
AAAAAAAAAA
Beginner
1,067 Views

I discovered that if I use an Altera USB-Blaster II it works perfectly fine. If, after this, I replace the Altera USB-Blaster with the Terasic one, it keeps working until something that I don't know happens, and then it stops working again (this "something that I don't know" is not closing/opening Quartus, it is not logging out and in in Ubuntu). Now it will fail until I program the FPGA once with the Altera USB blaster, then I can go back to the Terasic blaster but I know it will fail at some point and I will have to go back to the Altera blaster.

YuanLi_S_Intel
Employee
1,058 Views

I’m glad that your issue has been solved by changing to USB Blaster II.


I now transition this thread to community support. If you have a new question, feel free to open a new thread to get the support from Intel experts. Otherwise, the community users will continue to help you on this thread. Thank you.


dungeonlords
Beginner
424 Views

I have got the same problem on Ubuntu 20, Quartus 21.1 Lite with Altera USB Blaster Rev C. I try to work with omdazz cyclone iv board:

Can't access JTAG chain

 

How I can fix it?

 

P.S. There is no rc.local on Ubuntu 20.

LeviMe
Beginner
420 Views

Using Linux and the same JTAG device family, I got the same problem.

The solution I found works but it has to be repeated every time, unless it is automated with a script during the execution process.

 

You have to kill and restart the JTAG server on your computer:

  1. Open a command prompt and look for a process named 'jtagd'.
  2. If there is one active, kill it using the usual kill command.
  3. Plug the JTAG blaster and then turn on the FPGA device.
  4. launch the jtagonfig command (<installation_folder>/quartus/bin) in sudo mode.

 

You should get your device listed with a message looking like this:

1) USB-Blaster [1-3]
020F10DD 10CL006(Y|Z)/10CL010(Y|Z)/..

which means that your board is now fully connected and ready to receive your program.

 

If it didn't work, you have to do the steps 1,2 and 4 again. Additionally you might need to close the Quartus GUI so as to remove any defunct Jtagd process.

 

 

Lattice
Beginner
409 Views

I start my computer with Ubuntu 20. I not opened Quartus.  I open terminal and

killall jtagd

 

Than I connect Blaster to pc, connect FPGA board from OMDAZZ and switch on FPGA Board ( I use USB B connector).

sudo ./jtagconfig

Fails:

Unable to read device chain - JTAG chain broken

 

See screen. Need help.

jozephka99
New Contributor II
384 Views

You can try:

$sudo killall jtagd

then you must restart jtagd from:

$cd <Quartus path>/<Quartus version>/quartus/bin/

(mine path: ~/intelFPGA_lite/20.1/quartus/bin/)

$./jtagd

or

$./jtagd --user-start

then you can look jtagconfig:

$./jtagconfig

 

If your drivers succesfully installed and usb blaster is connected the pc you can see like this in first line when you run jtagconfig:

1) USB-Blaster [1-3]

If usb blaster connected the fpga you can see the fpga device model in second line. If you can't see the second line disconnect all cables then connect blaster to fpga then power up the fpga then connect blaster to the pc and retry the above steps. 

Reply