Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
1,221 Views

Linux font/cursor spacing problem.

Hi Everyone, 

 

I am running Quartus Prime 17.1 Lite under Ubuntu 16.04 (64-bit). Everything seems to work properly except that I am experiencing a "spacing" problem with the cursor in the text editor. As I type, the cursor seems to move across the screen faster than the text. You would expect the cursor to always be just to the right of the last letter typed, and it is at the very left side of the editor. However, midway across the editor windows, the cursor is approximately 3 characters farther right than the last letter and by the right side of the editor window it is 6 characters off. I have tried launching Quartus with the "--internal_anti_aliasing" option, but it makes no difference. I have also tried different fonts and the amount of offset does change but is never correct. I don't notice such a problem in any other applications I have, just Quartus. 

 

Has anyone else experienced this? Is there a remedy? 

 

Thanks. 

-Brian
0 Kudos
4 Replies
Altera_Forum
Honored Contributor I
137 Views

I had this as well. Sadly Ubuntu is not supported. I found that the "solution" was closing the file and reopening, not really good. In the end I ended up either remembering cursor positon for quick edits or switching to windows for bigger edits and writing new files.

Altera_Forum
Honored Contributor I
137 Views

Hi PietervanderStar, 

 

Thanks for the reply. It disappointing that there is no fix for this problem. I have tried closing and reopening the file and program but that doesn't seem make any difference for me. 

 

I did a quick run through of all of the available fonts and some work better than others. 

- "Courier 10 Pitch" and "MathJax_Typewriter" are close. The cursor is just slightly left of the character when you get to the extreme right side of the screen. 

- "Noto Sans" and "URW Palladio L" are off by the spcing of one character by the right side of the screen, which is noticeably better then the default font. 

- "Nimbus Mono L" has perfect spacing across the entire screen, it's just a slightly odd looking font. Kind of a smaller bold Sans Serif. 

Also changing the font size affects the offset error. There is probably some combination that works perfectly. 

 

The slight offset error is annoying but not enough to chase me back to Windows at this point. 

 

Again, thanks to the info. 

-Brian
Altera_Forum
Honored Contributor I
137 Views

I'm using Font: Liberation mono ,size: 12, style: regular. That mostly works. When it doesn't, I switch to Geany to edit the files.

Altera_Forum
Honored Contributor I
137 Views

Hi MaxplusII4ever, 

 

I tried your suggestion of Liberation Mono 12 Regular. Unfortunately for me it creates and even bigger offset. I also tried setting the size to 9 but then the spacing become wrong in the opposite direction. (My cursor ends up in the middle of some text.) I guess what works might depend on screen resolution and other factors. Thank for the suggestion anyways. 

 

-Brian
Reply