Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
The Intel sign-in experience has changed to support enhanced security controls. If you sign in, click here for more information.
16009 Discussions

MegaWizard Plug-In Manager didn't generate the .bsf file of IPCore

Honored Contributor II

Hi, everyone. 

I encountered a wierd trouble. 

When I try to add a IPCore into the Block Diagram and generate an IP Core using MegaWizard Plug-In Manager, I got the following warning after the generator works out and said "MegaCore Function Generation successful." 

The Warning said:"Block Symbol File xxxx.bsf is not generated from MegaWizard Plug-In Manager"  

The version of Quartus is 13.3 Lite 

And I'm sure that the path of .bsf file don't contain any space.
0 Kudos
2 Replies
Honored Contributor II



I have tried to recreate the warning but it successful to generated .bsf without warning used quartus 13.1 win10. 

Which version of quartus are you using(13.3!)? 

1.Regenerate and check if mega-wizard terminated in between process before generating the file? 

2.Have you checked in project directory for .bsf file?If it is not generated  

Try by deleting incremental_db and db folder or create new project and check. 


Different version of quartus. 


Let me know if you need any further assistance. 


Best Regards, 

Anand Raj Shankar 

(This message was posted on behalf of Intel Corporation)

I have the same problem with ALTMULT_COMPLEX that can't create the .bsd file. But others MegaCore function like ATLSQRT creates it. Is there a reason why? I tried Quartus 17.0, 17.1, 19.1. I normally install Quartus in D:\intelFPGA\ but I also tried with c:\intelFPGA to see if it was the SW path.


There is no space in my project path... it was D:\testing\


Any clues?


Best Regards,