Community
cancel
Showing results for 
Search instead for 
Did you mean: 
NSuku1
Beginner
1,617 Views

Microsoft visual studio 2017 professional with HLS

Hi!

 

I see that the HLS compiler (Quartus Prime Pro 18.1) works with Microsoft Visual Studio IDE 2015 Professional. I would like to know if it works with Visual Studio 2017 Professional?

 

Kindly confirm.

 

Thanks,

Nivetha

0 Kudos
8 Replies
AnandRaj_S_Intel
Employee
75 Views

Hi Nivetha,

 

Few quarters ago i was trying to use Quartus 17 std with Visual Studio 2017 but i was facing lot of issue so i used Visual Studio 2010 as per documents.

Presently i am using Quartus 17, 18 both std & pro edition with Visual Studio 2010 for simple design, so far i have not faced any issue.

However the Intel HLS Compiler software does not support versions of Microsoft Visual Studio other than those specified for the edition of the software.

 

Let me know if this has helped resolve the issue you are facing or if you need any further assistance.

 

Best Regards,

Anand Raj Shankar

75 Views

Hi Nivetha,

 

As pointed out by @Anand​ 

 

Please refer to Intel HLS Getting Starter guide to see the version of Visual Studio/ GCC supported .

 

Un-fortunately Intel HLS Compiler software does not support versions of Microsoft Visual Studio other than those specified for the edition of the software.

 

https://www.intel.com/content/dam/www/programmable/us/en/pdfs/literature/hb/hls/ug-hls-getting-start...

 

temp_hls_gcc_visual_studio_version.PNG

 

Thanks,

Arslan

NSuku1
Beginner
75 Views

Okay. Thanks for the clarification.

 

Nivetha

NSuku1
Beginner
75 Views

Hi all!

 

Can I use some other IDE other than Microsoft visual studio 2010 ?

 

Please let me know!

 

Thanks,

Nivetha

75 Views

You can try using Eclipse following the guide.

 

https://www.intel.com/content/altera-www/global/en_us/index/documentation/xfy1510159781700.html

 

Thanks,

Arslan

NSuku1
Beginner
75 Views

Okay. Thank you.

 

Best,

Nivetha

NSuku1
Beginner
75 Views

Hi all!

 

I'm using Intel Quartus Prime software standard version. As per the specification given by Intel, I can use Microsoft Visual Studio 2010 Professional for HLS development. However, I could not download this older version of Microsoft Visual Studio as it is not available in the original website.

 

I hope there should be some alternative to this issue.

 

Thanks,

Nivetha

75 Views

Did you tried the Eclipse ?

 

You can download Microsoft Visual Studio 2010 from link below.

https://visualstudio.microsoft.com/vs/older-downloads/

 

Thanks,

Arslan

Reply