Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
14964 Discussions

Modelsim Altera Functional Simulation Problem: Error: (vsim-13) Recompile work.PROJECTNAME because work.PROJECTNAME_data_type has changed.

BMcLa1
Beginner
443 Views

Hi Everyone,

 

I am having problems using the functional simulation tool when testing a given waveform input. I was not previously experiencing problems with this tool, but since I started using a package to define a custom type, and implemented it using the work library in my architecture (same as shown here: https://stackoverflow.com/questions/28187621/how-to-declare-output-array-in-vhdl), I have run into the errors shown below:

intel_troubleshoot.png

 

I was wondering if someone would be able to advise me please?

 

Many thanks,

 

B

0 Kudos
3 Replies
RichardTanSY_Intel
313 Views

This may be due to libraries that are used for simulation are precompiled and need to be refreshed.

Inside the Modelsim GUI, Go to the library tab inside Modelsim, right click on the work library and select refresh.

 

Let me know if it helps.

BMcLa1
Beginner
313 Views

Hi,

 

Thank you very much for your advice. I tried refreshing the work library and re running the functional simulation. Unfortunately, I still receive the same errors.

 

I was wondering if you have any other suggestions please?

 

Thanks.

RichardTanSY_Intel
313 Views

How about rebuilding your ModelSim project?

Reply