Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
15556 Discussions

Modelsim & VHDL Configuration

Altera_Forum
Honored Contributor II
808 Views

Hi, 

I have one entity in a file and several architectures in separe files. 

Each architecture file have a configuration statement. 

 

configuration CONFIGURATION_NAME of INSTANTIATING_ENTITY is for INSTANTIATING_ARCH for INSTANCE_NAME : COMPONENT_NAME use entity LIBRARY_NAME.ENTITY_NAME(ARCHITECTURE_NAME); end for; end for; end CONFIGURATION_NAME; 

 

and I call vsim like that : vsim -novopt LIBRARY_NAME.CONFIGURATION_NAME  

 

I wanted to speed up simulation so I removed -novopt and the design failed to be loaded. 

 

Can you confirm Modelsim does not support configuration feature in optimized mode ? ( tried on 10.0e and 10.5c) 

 

Best regards
0 Kudos
1 Reply
Altera_Forum
Honored Contributor II
104 Views

Hi, 

 

The issue maybe due to the fact that you have earlier compiled and simulated the design using the vopt switch. You could try by recompiling the design and then simulating using it without using the vopt argument. This happens because the earlier compilations and simulations would have produced an optimized simulation database, and when you try and simulate the same deign(database) without the optimization the tool will throw errors.  

 

All you need to do is to recompile the entire design and simulate it again without using the optimization (vopt).
Reply