Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
Announcements
The Intel sign-in experience is changing in February to support enhanced security controls. If you sign in, click here for more information.
15809 Discussions

Modelsim instance window error

lutzek
Novice
449 Views

Hello, 

I have a problem with ModelSim Altera Starter Edition 10.1d (used with Quartus II 13.1). The project is based on Cyclone III, so I cannot use newer software. The problem started, when I moved the project to the newer computer with Win10. Reinstalation did not help.

 

I'm receiving following errors when trying to import design via tcl sript:

# **** Error: LoadCompleteQ cmd: Transcript::ViewSimPanes sim
# ****        ** Error: (vsim-4005) Invalid argument 'AssertionScope'.

# ContextView configure: -filter <filter-list>** Error: (vsim-4005) Invalid argument 'UPF'.

# ContextView configure: -filter <filter-list>
# ** Error: (vsim-4005) Invalid argument 'AssertionScope'.

# ContextView configure: -filter <filter-list>** Error: (vsim-4005) Invalid argument 'UPF'.

# ContextView configure: -filter <filter-list>
#     while executing
# "Structure::CreateWindow $dataset_name"
#     (procedure "Transcript::ViewSimPanes" line 26)
#     invoked from within
# "Transcript::ViewSimPanes sim"
#     ("eval" body line 1)
#     invoked from within
# "eval $p $tankNamespace "

 

And

 

# **** Error: LoadCompleteQ cmd: Transcript::ViewSimPanes sim
# ****        can't rename to "::.main_pane.structure.interior.cs.body.struct": command already exists
# can't rename to "::.main_pane.structure.interior.cs.body.struct": command already exists
#     while executing
# "$vsimPriv(windowmgr) ShowWindow $windowobj"
#     (procedure "Structure::CreateWindow" line 23)
#     invoked from within
# "Structure::CreateWindow $dataset_name"
#     (procedure "Transcript::ViewSimPanes" line 26)
#     invoked from within
# "Transcript::ViewSimPanes sim"
#     ("eval" body line 1)
#     invoked from within
# "eval $p $tankNamespace "

 

 

 

Screenshot_4.png

 

The simulation is running, but I cannot see a project structure window.

I created a test project to investigate that. The whole code in project is:

Main file:

 

 

 

module Test_Project(
	A,
	B,
	AND_OUT
);

input wire	A;
input wire	B;
output wire	AND_OUT;

assign	AND_OUT = A & B;

endmodule

 

 

 

 

Test bench:

 

 

`timescale 1 ns / 1 ns
module TestBench();
	reg A=1'b0; 
	reg B=1'b1;
	wire	AND_OUT;

	
	Test_Project uut(
		A,
		B,
		AND_OUT
	);
	
	always #20 A = ~A;
	always #40 B = ~B;
	
endmodule

 

 

 

 

TCL file, that loads the script:

 

 

#init_tk
echo "Creating library"

cd {D:\Projects\FPGA\Test_Project\simulation\modelsim}

vlib ./work
vmap work ./work

#echo "Adding library"
#vlib altera_mf_ver
#vmap altera_mf_ver ./altera_mf_ver

#echo "Compiling library"
#vlog -work ./altera_mf_ver "D:/Software/altera/13.1/quartus/eda/sim_lib/altera_mf.v"

echo "Compiling modules"
vlog -work ./work "D:/Projects/FPGA/Test_Project/Test_Project.v"
vlog -work ./work "D:/Projects/FPGA/Test_Project/TestBench.v"


echo "Load/Simulate the design"
vsim -L altera_mf_ver TestBench -t ns

echo "Done."
vsim -L altera_mf_ver TestBench -t ns

echo "Done."

 

 

 

Do you know where the problem could be? 

 

 

 

0 Kudos
1 Solution
lutzek
Novice
394 Views

Hello Richard, 

 

Thank you for support. That was on revision: 2012.11. There is definitelly some compatibility problem, because I run the project with Modelsim Starter Edition 10.5b revision 2016.10 and it works perfectly. 

So my advice to other users would be to write a Cyclone III code in Quartus II 13.2 and test it in Modelsim 10.5b that is in a package with Quartus Prime.

View solution in original post

3 Replies
RichardTanSY_Intel
412 Views

I am able to install ModelSim ALTERA STARTER EDITION 10.1d Revision: 2012.11 and run the simulation successfully.

Below are the steps that I did.

  1. I just create a new project in Modelsim, added the Test_Project and the TestBench files that you provided.
  2. Compile both files.
  3. Run vsim -L altera_mf_ver TestBench -t ns
  4. Add wave and Run 2000

 

RichardTanSY_Intel_0-1651840239746.png

I think this is mostly a bad installation but you mentioned you have try to reinstall before, so I am stumped as to why you are still facing this issue. 

https://community.sw.siemens.com/s/question/0D54O00006mFTprSAG/modelsim-cant-open-structure-window

 

Best Regards,

Richard Tan

 

lutzek
Novice
395 Views

Hello Richard, 

 

Thank you for support. That was on revision: 2012.11. There is definitelly some compatibility problem, because I run the project with Modelsim Starter Edition 10.5b revision 2016.10 and it works perfectly. 

So my advice to other users would be to write a Cyclone III code in Quartus II 13.2 and test it in Modelsim 10.5b that is in a package with Quartus Prime.

RichardTanSY_Intel
376 Views

Great to hear that! I’m glad that your question has been addressed.

With that, I will now transition this thread to community support. If you have a new question, feel free to open a new thread to get the support from Intel experts. Otherwise, the community users will continue to help you on this thread. Thank you.


Best Regards,

Richard Tan


p/s: If any answer from the community or Intel support are helpful, please feel free to give Kudos. 


Reply