Showing results for 
Search instead for 
Did you mean: 

Nios II SBT Crashing on Linux

I'm having a problem when trying to open the Nios II SBT from Quartus on Linux. I've tried to use Quartus 18.1 and 20.1.

When opening from the directory "quartus/nios2eds/bin/eclipse-nios2" using the terminal, I got the mesage: "Free(): Invalid Pointer" and the program crashes.

When using Quartus 20.1, I followed the instalation steps of the Nios II SBT on the README file.

I also tried to open from "quartus/nios2eds/bin/eclipse_nios2/eclipse". This one opens, but I'm unable to create a project, because the program does not find the CPU on the .sopcinfo file. I always get the mesage "sopcinfo does not contain any cpu".

Thank you in advance,

Felipe Plech

0 Kudos
4 Replies

Hi Felipe,

First of all, thank you for reaching us.

you may have a Java issue, that's why the program crashed, please install it again.

Talking about using Quartus 20.1, did you make any change to your design in the platform designer before trying to open Nios II SBT and create the project?

  • Make sure you instantiated the NIOS II processor for your design in the Platform Designer tool.
  • In case you did, it's important to remember always click on Generate HDL after any change in Platform Designer because this is the moment when the *.sopcinfo file is created.
  • when the design is created, there's some *.sopcinfo created additional to the one which has the CPU instantiated, so make sure it's pointing to the right one.

If you keep having this issue, please share your design with us if there is the possibility.


-Eliath Guzman


Hi Eliath,

Thank you for the answer.

I've tried reinstalling Java and running with OpenJDK and Oracle, but I had no success. Both retuned the same error mentioned on my last message.

I got it working by installing Quartus 19.1. I followed the same steps that I mentioned. This versions gives me no error. It was not a problem with the .socpinfo file, but with the NIOS II SBT.

Furthermore, i tried with two linux distributions: Pop_OS! and Linux Mint. Both had the same results.

It looks like there is a problem on the eclipse plugin for NIOS II SBT, because without extracting the plugin to the eclipse mars.2 folder, the software runs ok, but after extraction, it gives me the error.

But, as I said, the version 19.1 is running without problems.

Thank you again,

Felipe Plech
0 Kudos

Hi Felipe,

I'm glad to read version 19.1 is running without any issue.

Once again thank you for contacting us, I'll keep debugging the initial issue so we can fix it in future versions.


-Eliath Guzman

0 Kudos
New Contributor I

The following workaround seems to work, it essentially replace Quartus included java engine with Java 8


cd ..../intelFPGA/20.1/quartus/linux64
mv jre64 jre64_old
ln -s /lib/jvm/java-1.8.0-openjdk-amd64/jre jre64


the path to Java 8 jre might be machine specific, mine is at least placed there

0 Kudos