Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Valued Contributor III
752 Views

Programming Flash memory failed

Hi, 

 

I am using CycloneIII FPGA, Quartus11.1sp1 & NIOS IDE tool. 

I am able to load sof file using quartus tool. 

I need to burn sof file using NIOS IDE tool into my flash memory using JTAG.  

when i tried to burn flash i am getting below error messages continuously. 

erase failed at offset d0000  

programming at a0000 failed... the address is not constant every time, it is changing randomly. 

 

I tried more than 30 to 40 times but still error is coming.My data transfer from FPGA to PC is through Ethernet(TCP/IP) protocol. Once the flash is programmed i can ping my FPGA board using Ethernet protocol.  

I have given all the setting in NIOS project build. 

 

note: This NIOS IDE project is working for all the FPGA's except few. 

 

We verified all the voltage and current levels of our board ... looking everything is fine. 

 

I am attaching the my NIOS IDE project settings and error msgs. 

 

Any one please help on this.....
0 Kudos
0 Replies