Community
cancel
Showing results for 
Search instead for 
Did you mean: 
TAnde27
Beginner
423 Views

Quartus 18.1 Lite on Windows 10: DDR3L SDRAM Uniphy, IP core generation FAILS.

I am trying to generate a DDR3L Uniphy Memory controller in Quartus 18.1 Lite on my Windows 10 machine. When I run the IP generation from the MegaWizard, I see many errors (log attached), and the final status of the IP core says "Generation FAILED".

 

Some initial troubleshooting efforts which have not worked:

1.) Per post here I made sure that my Windows TEMP and HOMEDRIVE environmental variables were set to my C local drive. No luck.

 

2.) Just in case this was related something goofy in names for the working directory, I attempted to generate a completely new IPcore in the top level of the local C drive. Still, no luck.

 

3.) I temporarily disabled my firewall and antivirus, just in case it was interfering with the scripts. (Although, I don't have a reason to think that this was the case.) No luck.

 

4.) I made sure my user account had full read/write permissions for the Quartus 18.1 Lite install . (I doubt this is required, but I wanted to try everything I could think of). No luck.

 

I'm at a lost as to what to try next, but this is rather time critical. Please advise.

 

Thanks,

 

Tyler

0 Kudos
1 Reply
NurAida_A_Intel
Employee
64 Views

Hi Sir,

 

Thank you for joining this Intel Community.

 

I did some searching and found a similar error message and a workaround that may help.

 

1) In Task Manager, is there a bash.exe sub-process ? Looks like this is seen when Windows “Subsystem for Linux” is selected (point 2)

 

2) In Control Panel -> Programs And Features -> Turn windows features on or off,   is the Windows “Subsystem for Linux” selected ?

 

If it is, can you try un-selecting it and see if the error still occurs. 

 

Suggest you close down Quartus, unselect Windows “Subsystem for Linux", save the settings, reboot PC, open Quartus and qsys and regenerate qsys (just to make sure the Windows “Subsystem for Linux” is identified correctly unselected)

 

Hope this helps.

 

Regards,

NAli1