Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
802 Views

Quartus Compile Design text immediately reverts to yellow

I am experiencing a strange problem in Quartus Prime. It has to deal with the "Compile Design" text automatically reverting back to yellow immediately after the "Compile Design" sequence has completed. This problem seems to occur whenever I have "regenerated" a QSYS block, but have not closed and reopened Quartus.  

 

Here is an example of it not happening: 

Step 1) Open Quartus Prime 

Step 2) Open QSYS 

Step 3) Regenerate QSYS 

Step 4) Close QSYS 

Step 5) Close Quartus Prime 

Step 6) Reopen Quartus Prime 

Step 7) "Compile Design" --> Text transitions from yellow to green as each step completes. When "Compile Design" is complete, the text stays green. 

 

Here is an example of it happening: 

Step 1) Open Quartus Prime 

Step 2) Open QSYS 

Step 3) Regenerate QSYS 

Step 4) Close QSYS 

Step 4) "Compile Design" -> Text transitions from yellow to green as each step completes. When "Compile Design" is complete, all text reverts back to yellow. 

 

Any ideas why this is happening and how to get it to stop? We are planning on having a TCL script regenerate QSYS every time, but would also like to see green in the end.
0 Kudos
2 Replies
Altera_Forum
Honored Contributor I
28 Views

Which version of Quartus? Are you using regular Qsys or Qsys Pro?

Altera_Forum
Honored Contributor I
28 Views

For Quartus: 

 

I was seeing it with: Quartus Prime Version 16.1.2 build 203 01/18/2017 SJ Lite Edition 

I noticed the same problem on earlier 16.X versions. 

I also am still seeing it with Quartus version: 17.0.0 Build 595 04/25/2017 SJ Lite Edition 

 

For QSYS: I am not using Qsys Pro. 

QSYS Version: 17.0 Build 595
Reply