Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)

Quartus Fitter Crashing

mikeyl
Novice
3,366 Views

Hi, I'm looking to get some help to get my Quartus to work for my digital logic/comp org class. Its been giving me quite a headache. Currently I have the M1 Pro Macbook and I need to run Quartus using a Parallel Boot/VM. I'm able to install Quaratus and compile it however I run into an error while fitting. Is there anything I can do to fix this error. Thank you! 

 

Problem Details
Error:
Internal Error: Sub-system: DYGR, File: /quartus/ddb/dygr/dygr_place_info.cpp, Line: 3270
 
Stack Trace:
    0x48b8c: DYGR_BLK_PHYSICAL_IMPLEMENTATION::PORT_ID::operator unsigned __int64 + 0x2bb4c (DDB_DYGR)
    0x1e780: std::_Hash<std::_Umap_traits<DYGR_BLK_PHYSICAL_IMPLEMENTATION::PORT_ID,DYGR_BLK_PORT_INFO const * __ptr64,std::_Uhash_compare<DYGR_BLK_PHYSICAL_IMPLEMENTATION::PORT_ID,STL_HASH_FUNCTOR<DYGR_BLK_PHYSICAL_IMPLEMENTATION::PORT_ID>,std::equal_to<DYGR_BLK_PHYSICAL_IMPLEMENTATION::PORT_ID> >,std::allocator<std::pair<DYGR_BLK_PHYSICAL_IMPLEMENTATION::PORT_ID const ,DYGR_BLK_PORT_INFO const * __ptr64> >,0> >::_Hashval + 0x10 (DDB_DYGR)
    0x1fc3e: std::unordered_map<DYGR_BLK_PHYSICAL_IMPLEMENTATION::PORT_ID,DYGR_BLK_PORT_INFO const * __ptr64,STL_HASH_FUNCTOR<DYGR_BLK_PHYSICAL_IMPLEMENTATION::PORT_ID>,std::equal_to<DYGR_BLK_PHYSICAL_IMPLEMENTATION::PORT_ID>,std::allocator<std::pair<DYGR_BLK_PHYSICAL_IMPLEMENTATION::PORT_ID const ,DYGR_BLK_PORT_INFO const * __ptr64> > >::operator[] + 0x1e (DDB_DYGR)
    0x1db2b: DYGR_BLK_PHYSICAL_IMPLEMENTATION::populate_port_info_transient_data + 0xff (DDB_DYGR)
    0x189d6: DYGR_PLACE_INFO_BODY::set_transient_data_members + 0x66 (DDB_DYGR)
    0x3433b: DYGR_PLACE_INFO_BODY::load_data_from_pdb + 0x83 (DDB_DYGR)
    0x15360: DYGR_DIE_INFO_BODY::load_data + 0x2a4 (DDB_DYGR)
    0x1d1f7: MPP_ROOT::start + 0x587 (COMP_MPP)
     0x5e5a: qfit_execute_mpp + 0x42 (comp_qfit_legacy_flow)
     0x555b: QFIT_FRAMEWORK::execute + 0x22f (comp_qfit_legacy_flow)
     0x2768: qfit_legacy_flow_run_legacy_fitter_flow + 0x1d4 (comp_qfit_legacy_flow)
    0x14410: TclInvokeStringCommand + 0xf0 (tcl86)
    0x161e2: TclNRRunCallbacks + 0x62 (tcl86)
    0x17a65: TclEvalEx + 0xa65 (tcl86)
    0xa6f8b: Tcl_FSEvalFileEx + 0x22b (tcl86)
    0xa5646: Tcl_EvalFile + 0x36 (tcl86)
    0x12877: qexe_evaluate_tcl_script + 0x367 (comp_qexe)
    0x11ac3: qexe_do_tcl + 0x343 (comp_qexe)
    0x16c34: qexe_run_tcl_option + 0x584 (comp_qexe)
    0x39285: qcu_run_tcl_option + 0xf95 (comp_qcu)
    0x1658d: qexe_run + 0x39d (comp_qexe)
    0x17371: qexe_standard_main + 0xc1 (comp_qexe)
     0x2262: qfit2_main + 0x82 (quartus_fit)
    0x13258: msg_main_thread + 0x18 (CCL_MSG)
    0x14a5e: msg_thread_wrapper + 0x6e (CCL_MSG)
    0x16af0: mem_thread_wrapper + 0x70 (ccl_mem)
    0x12af1: msg_exe_main + 0xa1 (CCL_MSG)
     0x2a02: __tmainCRTStartup + 0x10e (quartus_fit)
    0xeae0b: uaw_wcsrchr + 0xe534b (KERNEL32)
    0x84a5f: uaw_wcsrchr + 0x7ef9f (KERNEL32)
   0x1bac4f: ZwWaitLowEventPair + 0x1ac5cf (ntdll)
 
End-trace


Executable: quartus_fit
Comment:
None

System Information
Platform: windows64
OS name: Windows 10
OS version: 10.0

Quartus Prime Information
Address bits: 64
Version: 20.1.1
Build: 720
Edition: Lite Edition

 

0 Kudos
27 Replies
sstrell
Honored Contributor III
2,751 Views

The first step for Quartus crashing is to always delete the db and incremental_db folders from your project directory, start Quartus again, and recompile from scratch.

mikeyl
Novice
2,740 Views

Yup I've tried this. Still crashes. Quartus doesn't close, just a popup says software crashed unexpectedly

Nurina
Employee
2,751 Views

Hi,


Can you share your .qar file so I can reproduce your error? To do this, go to Project>Archive Project.


Thanks,

Nurina


mikeyl
Novice
2,741 Views

Hi Nurina,

 

Just for some specifications, I'm currently using Windows 11 ARM on Parallel for Mac with M1 Pro. I've tried Quartus Prime Lite 21.0 and Quartus II and they both give the same issue. 

 

Thanks for your help,

Michael L.

Nurina
Employee
2,731 Views

Hi,


I tried compiling this on Quartus Lite 20.1.1 on my machine twice and both times I received different Internal Errors. However, I was able to compile this on Quartus Std 20.1. Are you able to migrate to Standard edition?


Regards,

Nurina


mikeyl
Novice
2,715 Views

Hi Nurina,

 

Oh interesting. I think Standard edition is paid for, so I'm not exactly sure. But I'll try.

 

Thank you,

Michael L

jmlarbaig
Beginner
2,704 Views

Hi everyone,

 

Have you find solution ? 

 

Thanks!

mikeyl
Novice
2,675 Views

Nope not yet. Can't afford Quartus Standard Edition for just a single class.

jmlarbaig
Beginner
2,672 Views

I see ! We are now two in this case .. may be !! hahah

sstrell
Honored Contributor III
2,665 Views

It doesn't make sense why it would work on Standard but not on Lite.  What is your target device and are you using any special features, like design partitioning or other options, that might not be available in Lite?

jmlarbaig
Beginner
2,655 Views

I complety agree with you. I try to just open an old project and when the project open, the error appear. 

 

I try Standard and not lite and the device is DE0-Nano-SoC. No special feature is used

mikeyl
Novice
2,514 Views

Mine is able to load and compile the first stage Analysis. My error appears on fitter. 

Nurina
Employee
2,615 Views

I can't seem to reproduce the error. When I compile on Lite edition there are instances where I can compile successfully. But when I don't, I see different types of Internal Errors.


Do you constantly see the Internal Error posted above? Do you see "Internal Error: Sub-system: DYGR, File: /quartus/ddb/dygr/dygr_place_info.cpp, Line: 3270" every time you try to compile?


I am reporting this matter to engineering and will let you know of any updates.


Regards,

Nurina


Nurina
Employee
2,607 Views

Hi,

Could you share your project in a zipped file? 

Thanks,

Nurina

jmlarbaig
Beginner
2,590 Views

I tried with the newest Quartus lite version and it worked. I think we need to update software. 

But there is few adaptation to do. For instance, install WSL for platform designer because, when the compilation procedure is working, there is some issues about that. 

mikeyl
Novice
2,515 Views

Sorry for the late replay as I've been busy with school. I've tried installing WSL on my virtual machine. But I've been getting an error with Ubuntu 20.04. Should I try a different version? Just a note, the error also pops up during the fitter stage. 

Nurina
Employee
2,274 Views

You could try the latest Lite version. Could you share a zipped file of your project?

 

Thanks,

Nurina

Nurina
Employee
2,062 Views

Hi,

We did not receive any response to the previous question/reply/answer that I have provided, thus I will put this case to close pending. Please post a response in the next 15 days to allow me to continue to support you. After 15 days, this thread will be transitioned to community support. The community users will be able to help you with your follow-up questions.

Regards,
Nurina

P/S: If you like my comment, feel free to give Kudos. If my comment solved your problem, feel free to accept my comment as solution!

Nurina
Employee
2,559 Views

@mikeyl , does the above comment help?

q1
Beginner
2,421 Views

@mikeyl , did you find a solution?  I'm in the exact same position as you.  Just bought a M1 mac and am trying to run Quartus Lite on Parallels

Reply