Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
14957 Discussions

Quartus II 13.1 Fatal Error: Segment Violation at (nil) in Ubuntu 14.04 32 bits

Altera_Forum
Honored Contributor I
1,378 Views

Hi, 

 

I'm getting the folowing error: 

 

*** Fatal Error: Segment Violation at (nil) 

Module: quartus 

Stack Trace: 

 

0x7d674: lh_insert + 0x94 (tls1.6) 

 

 

End-trace 

 

Quartus II 32-bit Version 13.1.4 Build 182 03/12/2014 SJ Web Edition 

 

I have tried to reinstall every thing from scratch, but did not work. As soon as the program starts the message pop up an the software closes. 

I would appreciate any help. Thanks.
0 Kudos
2 Replies
Altera_Forum
Honored Contributor I
212 Views

I am getting a similar crash using kubuntu-64bit 14.04 virtual machine (vmware 10.0) when I run quartus 32bit, but when I run quartus --64bit I get more trace output: 

 

*** Fatal Error: Segment Violation at (nil) 

Module: quartus 

Stack Trace: 

 

0x85ce3: lh_insert + 0xb3 (tls1.6) 

0x7a48c: OBJ_NAME_add + 0x6c (tls1.6) 

0x43f88: SSL_library_init + 0x38 (ssl) 

 

 

 

 

 

 

 

 

0x1a0056: QObject::event(QEvent*) + 0x376 (QtCore.so.4) 

0x1fd924: QApplicationPrivate::notify_helper(QObject*, QEvent*) + 0xb4 (QtGui.so.4) 

0x2024df: QApplication::notify(QObject*, QEvent*) + 0x12f (QtGui.so.4) 

0x18b27c: QCoreApplication::notifyInternal(QObject*, QEvent*) + 0x8c (QtCore.so.4) 

0x18e8a8: QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) + 0x328 (QtCore.so.4) 

 

0x18a062: QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) + 0x32 (QtCore.so.4) 

0x18a31d: QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) + 0x14d (QtCore.so.4) 

0x18ed4b: QCoreApplication::exec() + 0xbb (QtCore.so.4) 

0x7dc1: __gxx_personality_v0 + 0x3b9 (quartus) 

0x3bb9a: msg_main_thread(void*) + 0x10 (ccl_msg) 

0x75bc: thr_final_wrapper + 0xc (ccl_thr) 

0x3c801: msg_thread_wrapper(void* (*)(void*), void*) + 0x5b (ccl_msg) 

0x16e45: mem_thread_wrapper(void* (*)(void*), void*) + 0xc5 (quartus) 

0xf41d: err_thread_wrapper(void* (*)(void*), void*) + 0x27 (ccl_err) 

0x799c: thr_thread_wrapper + 0x15 (ccl_thr) 

0x4e41d: msg_exe_main(int, char const**, int (*)(int, char const**)) + 0x96 (ccl_msg) 

0x7e85: __gxx_personality_v0 + 0x47d (quartus) 

0x21ec5: __libc_start_main + 0xf5 (c.so.6) 

0x7c99: __gxx_personality_v0 + 0x291 (quartus) 

 

End-trace 

 

Quartus II 64-Bit Version 13.1.0 Build 162 10/23/2013 SJ Web Edition
Altera_Forum
Honored Contributor I
212 Views

I am using RHEL 5.5 I am facing the same error. Can some one please help me to solve this problem ? 

 

*** Fatal Error: Segment Violation at 0x4 

Module: quartus 

Stack Trace: 

0x1741e: atcl_set_package_version(char const*, char const*, bool) + 0x94 (ccl_atcl) 

0x1a81c: ATCL_HELP::set_package(char const*, char const*, char const*, char const*, bool) + 0x88 (ccl_atcl) 

0x1a8f7: atcl_begin_package_setup(char const*, char const*, char const*, char const*, bool) + 0x46 (ccl_atcl) 

0xb4f9d: tdb_advanced_tdb12_unregister_tcl + 0x79 (tsm_tdb) 

0xb4fe2: Advanced_tdb12_Unload + 0x14 (tsm_tdb) 

0xb3f39: TDB_AUTO_ADVANCED_TDB12_TCL_INIT::~TDB_AUTO_ADVANCED_TDB12_TCL_INIT() + 0x29 (tsm_tdb) 

0x2c1b9: __cxa_finalize + 0xa9 (c.so.6) 

 

0xd3a: dlclose + 0x2a (dl.so.2) 

0x87bd: thr_drl_native_unload + 0x35 (ccl_thr) 

0x8bef: thr_drl_unload_internal + 0x61 (ccl_thr) 

0x8ccf: thr_drl_unload_dependents + 0x9b (ccl_thr) 

0x8c1b: thr_drl_unload_internal + 0x8d (ccl_thr) 

0x9823: thr_drl_unload_all + 0x3f (ccl_thr) 

0x997f: thr_drl_fini + 0x8 (ccl_thr) 

0x9b04: THR_INITIALIZER::~THR_INITIALIZER() + 0x14 (ccl_thr) 

0x2c1b9: __cxa_finalize + 0xa9 (c.so.6) 

 

0x2bf09: exit + 0xe9 (c.so.6) 

 

0xd0c4: _IceWrite + 0xf4 (ICE.so.6) 

0xd102: IceFlush + 0x32 (ICE.so.6) 

0x2a17: SmcSetProperties + 0x287 (SM.so.6) 

 

0x55e9: _SmcProcessMessage + 0xe49 (SM.so.6) 

0x12059: IceProcessMessages + 0x3c9 (ICE.so.6) 

 

0x195ec2: QMetaObject::activate(QObject*, QMetaObject const*, int, void**) + 0x272 (QtCore.so.4) 

0x1e5873: QSocketNotifier::activated(int) + 0x43 (QtCore.so.4) 

0x19cb27: QSocketNotifier::event(QEvent*) + 0x147 (QtCore.so.4) 

0x1566b4: QApplicationPrivate::notify_helper(QObject*, QEvent*) + 0xb4 (QtGui.so.4) 

0x15b31e: QApplication::notify(QObject*, QEvent*) + 0x15e (QtGui.so.4) 

0x17defb: QCoreApplication::notifyInternal(QObject*, QEvent*) + 0x7b (QtCore.so.4) 

0x1afb58: QEventDispatcherUNIX::activateSocketNotifiers() + 0xe8 (QtCore.so.4) 

0x1b0816: QEventDispatcherUNIXPrivate::doSelect(QFlags<QEventLoop::ProcessEventsFlag>, timeval*) + 0x2b6 (QtCore.so.4) 

0x1b1326: QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) + 0xb6 (QtCore.so.4) 

 

0x181ee1: QCoreApplication::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) + 0x41 (QtCore.so.4) 

0x1b24fa: QWidgetPrivate::show_helper() + 0x26a (QtGui.so.4) 

0x1b276b: QWidget::setVisible(bool) + 0x1cb (QtGui.so.4) 

0x42200: QUI_APP::process_cmdline_arguments_pre_main_wnd_create(QUI_CMDLINE*) + 0xa0 (sys_qui) 

0xc31c9: QUI_APP::init_instance(int, char const**, QUI_CMDLINE*) + 0x17f (sys_qui) 

0x10bc9: QGQ_APP::init_instance(int, char const**, QUI_CMDLINE*) + 0x143 (sys_qgq) 

0x63be: __gxx_personality_v0 + 0x35a (quartus) 

0x281da: msg_main_thread(void*) + 0x18 (ccl_msg) 

0x529e: thr_final_wrapper + 0xe (ccl_thr)
Reply