Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Valued Contributor III
1,406 Views

Quartus II v15.0.0.145 Device Installer fails Cyclone IV install

I downloaded both Quartus v15.0 and the Cyclone IV (web versions) today. 

 

I installed Quartus without problems. 

 

Next I ran the Device Installer and it fails with the message "Unknown element Aria10_part1" 

 

The link to Software Installation FAQs is broken. 

 

I am using Windows 8.1 64-bit and the standalone device installer. 

 

Am I doing something wrong ??? 

 

potedit: also fails to install max10 with the same error.
0 Kudos
12 Replies
Highlighted
Valued Contributor III
1 View

Re: Quartus II v15.0.0.145 Device Installer fails Cyclone IV install

Colleagues have confirmed Windows 8.1 64bit fails, and Windows 7 64bit works. 

Seems it is the Device Installer program at fault.
0 Kudos
Highlighted
Valued Contributor III
1 View

Re: Quartus II v15.0.0.145 Device Installer fails Cyclone IV install

I am using Windows 7sp1 64 bit and the installation works as well. I believe it might due to Windows compatibility issue. You might want to highlight this to Altera support team.

0 Kudos
Highlighted
Valued Contributor III
1 View

Re: Quartus II v15.0.0.145 Device Installer fails Cyclone IV install

One of my colleagues tried the Arria Device, and it also fails under Windows 8.1 

 

However, seems I cannot log a Service Request because we don't have a valid company email address despite being in business since 1976 designing and programming computer gear for Apple, ICL (now part of Fujitsu), etc.
0 Kudos
Highlighted
Valued Contributor III
1 View

Re: Quartus II v15.0.0.145 Device Installer fails Cyclone IV install

Try contacting your local FAE.

0 Kudos
Highlighted
Valued Contributor III
1 View

Re: Quartus II v15.0.0.145 Device Installer fails Cyclone IV install

The local FAE is useless. I tried to get a quote for some Cyclone IV parts, and, after providing all the details of my project that they required first, they didn't even bother to give me quote.

0 Kudos
Highlighted
Valued Contributor III
1 View

Re: Quartus II v15.0.0.145 Device Installer fails Cyclone IV install

A colleague uninstalled and reinstalled with the Device files in the same directory as the Quartus Installer .exe (a 1 hour process). 

This worked for him, so I tried it and it was successful. 

 

This doesn't resolve the issue that the Device Installer does not work with Windows 8.1 

 

I will need to do this uninstall/install process again when I download the Cyclone V device file :(
0 Kudos
Highlighted
Valued Contributor III
1 View

Re: Quartus II v15.0.0.145 Device Installer fails Cyclone IV install

I dont think that window 8.1 is suppoted yet. can you check in altera website

0 Kudos
Highlighted
Valued Contributor III
1 View

Re: Quartus II v15.0.0.145 Device Installer fails Cyclone IV install

I check the Altera web at https://www.altera.com/support/support-resources/download/os-support.html, the Windows 8.1 should be supported by the QII 15.0. 

 

Since you do not have a valid company email, probably you can ask your FAE to help log a service request for you.
0 Kudos
Highlighted
Valued Contributor III
1 View

Re: Quartus II v15.0.0.145 Device Installer fails Cyclone IV install

Try to reinstall with the device files in the same directory as mentioned by @cluso99. Mine works with this solution in Win8.1

0 Kudos
Highlighted
Valued Contributor III
1 View

Re: Quartus II v15.0.0.145 Device Installer fails Cyclone IV install

I have the exact same problem :/ 

 

Can't install any device after installation of Quartus. I guess I'll have to reinstall. Devs doesn't read these forums? It's like three weeks since first report..
0 Kudos
Highlighted
Valued Contributor III
1 View

Re: Quartus II v15.0.0.145 Device Installer fails Cyclone IV install

 

--- Quote Start ---  

I have the exact same problem :/ 

 

Can't install any device after installation of Quartus. I guess I'll have to reinstall. Devs doesn't read these forums? It's like three weeks since first report.. 

--- Quote End ---  

 

 

I think you need to try the workaround mentioned in this post. It works on my side. 

 

Just Use the QuartusSetupWeb-15.0.0.145-windows.exe to install your device, then put QuartusSetupWeb-15.0.0.145-windows.exe and max-15.0.0.145.qdz (or other qdz files) in the same directory. Next, launch QuartusSetupWeb-15.0.0.145-windows.exe, install to the same directory that you had Quartus II installed. 

 

You can also uninstall your previous installation, then install Quartus and devices all together at the same time. 

 

You can submit a report to altera, they might provide you a patch for this before they released it officially.
0 Kudos
Highlighted
Valued Contributor III
1 View

Re: Quartus II v15.0.0.145 Device Installer fails Cyclone IV install

Workaround: 

1. Put the desired devices (xxx.qdz files) in the same folder as the Quartus setup exe. 

2. Uninstall Quartus v15 

3. Resinstall Quartus v15 

 

Solution: 

Request the patch from Altera Support. I have verified this works and it only takes a minute or two to apply. 

 

FYI Altera Support did indeed work with me despite the original (automated) email about requiring a valid company email address.
0 Kudos