Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Novice
158 Views

Quartus Lite 18.1, custom IPs disappearing from list

Hi,

 

me and my colleagues created some custom components for use in a Nios system with Platform designer.

I was able to add the path of our custom IP repository (a local folder in c:\) to the IP search paths, and all is well.

 

Now, since yesterday, after some hours of work the custom IP have disappeared from the list, but the IP search path is still present and correct.

 

I see when loading a design in Platform Designer that the IP search path is found and "matched 1 files in 0 seconds" when there are multiple IPs.

 

The only way I found to fix this has been to completely uninstall and reinstall Quartus: yesterday I did so and it worked again.

This morning, again after some time, the IP have disappeared again!

 

How to solve this?

I read that there could be an IP cache somewhere that gets corrupt...

Can you help please?

 

PS if I take the IPs and move to a different path, then add that path to the IP search path, the components that I moved to the new path will show up fine. But this ONLY if the component files (.tcl etc) are in the ROOT of the IP search path. If I add them in a subdirectory, they don't show up anymore.

0 Kudos
1 Reply
Highlighted
21 Views

Hi Giaime,

 

I can't replicate the scenario using Quartus 18.1 Lite.May be issue with your setup environment attached image for reference

Try installing latest Quartus Lite version.

 

Regards

Anand

 

lib.JPG

0 Kudos