Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
All support for Intel NUC 7 - 13 systems has transitioned to ASUS. Read latest update.
16507 Discussions

Quartus Prime Lite 21.1 on Ubuntu 21.10 Questa does not start

New Contributor I

My laptop is running Ubuntu 21.10.

I just installed Quartus Prime Lite 21.1 which no longer includes ModelSim Starter Edition but Questa Intel FPGA Starter Edition instead.

According to Ubuntu is not supported to run Questa.

Is this really true?

I created a free license on the Self Service Licensing Center and entered the location of the license file in Quartus Prime Lite Options as well as the path /home/bert/intelFPGA_lite/21.1/questa_fse/bin in General/EDA Tool Options.

When I try to start in Tools/Run Simulation Tool/Gate Level Simulation I get

Info (22036): Successfully launched NativeLink simulation (quartus_sh -t "/home/bert/intelFPGA_lite/21.1/quartus/common/tcl/internal/nativelink/qnativesim.tcl" "Lab05" "Lab05")
Info (22036): For messages from NativeLink execution see the NativeLink log file /home/bert/FPGA/Labs_Companion/Lab05/Lab05_nativelink_simulation.rpt

But nothing happens.

Are there libraries that I should still install in Ubuntu to be able to run Questa?

0 Kudos
1 Solution
New Contributor I

Solved by editing the desktop file:
Edit /home/bert/Desktop/Quartus (Quartus Prime 21.1) Lite Edition.desktop
Exec=env LM_LICENSE_FILE=/home/bert/1-V4I9CH_License.dat /home/bert/intelFPGA_lite/21.1/quartus/bin/quartus --64bit

View solution in original post

0 Kudos
6 Replies
New Contributor I

Solved by editing the desktop file:
Edit /home/bert/Desktop/Quartus (Quartus Prime 21.1) Lite Edition.desktop
Exec=env LM_LICENSE_FILE=/home/bert/1-V4I9CH_License.dat /home/bert/intelFPGA_lite/21.1/quartus/bin/quartus --64bit

0 Kudos

Thanks a lot

I have done exactly as you suggested BUT this is what I get:

Unable to checkout a viewer license necessary for use of the Questa Intel Starter FPGA Edition graphical user interface. Vsim is closing

This is what in my case I have in my ~/Desktop/'Quartus (Quartus Prime 21.1.0) Lite Edition.desktop'

Exec=env LM_LICENSE_File=/home/cesar/bin/intelFPGA_lite/21.1.0/questa_fse/LR-075740_License.dat /home/cesar/bin/intelFPGA_lite/21.1.0/quartus/bin/quartus --64bi


0 Kudos
New Contributor I

I am now running Quartus Prime Lite 21.1.1, since July.

The trick still works for me.

Two remarks:

  • is your license file expired? Just request a new license and try again
  • probably copy/paste error but at the end of your line the 't' is missing in --64bit
0 Kudos

@CXHernandez I had the issue you were having.  Their does seem to be an issue where Questa ONLY looks at LM_LICENSE_FILE to find *ITS* license file.  To solve this, I specify the Quartus license using the dialog box's "License File" entry and specify the Questa license file using LM_LICENSE_FILE.  If you have managed to get BOTH licenses in the same file, you MIGHT be able to specify JUST that license file in the LM_LICENSE_FILE variable, but it does not seem to be the case since you are getting a license error.  Questa, I think was ALSO supposed to look at MGLS_LICENSE_FILE, but it appears not to ever look at this.  I can't tell you how much of a problem this caused us when we were trying to initially run the simulator, only to find out that it supposedly couldn't check out a license (we do have a license server, so I point Quartus to that and currently point Questa to a self-generated license).  We had a full license for modelsim, way back, and it didn't expire, but it doesn't work anymore it seems.  At any rate, we'll eventually sort out our license.  Just a note, you appear to have LM_LICENSE_File instead of LM_LICENSE_FILE as well, which also doesn't work.


@BertRAMAerts The issue I seem to be having is getting Quartus to compile the simulation library under Ubuntu 20.04.  It appears Intel isn't willing to support this, but now it appears someone had success.  I kept running into issues where vlog would not process the encrypted IP.  It seems to do the following:


1) I open the dialog.  I point the tool at "QuestaSim" and the executables location to the questa_fse/bin directory.  I select the output directory then press "Start compilation".  This always fails the first time and I have to modify the executables location to get it to take.

2) Once the compile starts, it fails with "Macro `<protected> is undefined which then reports a syntax error in protected region.


Did you run into these errors trying to build the simulation library?  I am trying to build for a MAX10, which uses the file fiftyfivenm_atoms_ncrypt.v, which seems to be where this error appears?

0 Kudos

Please kindly elaborate more on how you solved this issue.

0 Kudos

Hi @BertRAMAerts,


Thank you for posting in Intel community forum and hope all is well.
As well as appreciate the effort in sharing the solution for this, with no further clarification on this thread we will no longer monitor this thread.
Thank you for the questions and as always pleasure having you here.


Best Wishes

0 Kudos