Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
16653 Discussions

Quartus Prime Lite 23.1 PLL Wizard Problem

Nawaf
Beginner
2,695 Views

Hello, 

 

I am a beginner trying to use ALTPLL to generate a PLL IP.  The problem is that the MegaWizard quit when I reach the third step "Output Clocks" and don't allow me to continue the IP generation. First image shows the wizard and the step it quits at.  Second image shows the menu that appear after the wizard quit, when "yes" is pressed an empty .qip file get added to the project.

 

Am I doing something wrong? please help.

Labels (1)
0 Kudos
15 Replies
NazrulNaim_Intel
Employee
2,603 Views

Hi,

 

Sorry for the delay and thank you for reaching out. Allow me some time to look into your issue. I shall come back to you with findings.

 

Thank you for your patience.

 

Best Regards,

Nazrul Naim


0 Kudos
NazrulNaim_Intel
Employee
2,558 Views

Hello,


Sorry for the delay. Can I know which version of Quartus you are using, and which device are being used.


Best regards,

Nazrul Naim


0 Kudos
EKaya
Beginner
2,535 Views

Having the same issue with EP4CE10E22C8N Quartus Lite 23.1.std.0 build 991.

 

0 Kudos
NazrulNaim_Intel
Employee
2,482 Views

Hi,


Thank you for the update. I will get back to you as soon as I managed to find the solution.


Thank you for your patience.


Best regards,

Nazrul Naim


0 Kudos
NazrulNaim_Intel
Employee
2,469 Views

Hello,

 

For more information regarding the ALTPLL user guide. Can go through the link provided below.

 

Link : https://cdrdv2.intel.com/v1/dl/getContent/653943?explicitVersion=true&fileName=mfug_altpll.pdf

 

Hope that answers your question.

 

Best regards,

Nazrul Naim

 

0 Kudos
EKaya
Beginner
2,440 Views

Cyclone IV familiy definitely supports ALT PLL, since its introduction in 2009.. Here is a screen shot from Quartus 22.1...

BTW linked document is dated from 2006, Cyclone IV introduced in 2009... Of course ALTPLL can`t suport it in 2006..

/****/Solution/****/ 

Basic function is broken in version 23.1 ...

Either downgrading to <=22.1 or copying ALTPLL from 22.1 to 23.x solves the issue...

/****/

 

Have a nice day. 

 

 

Capture.JPG

0 Kudos
NazrulNaim_Intel
Employee
2,423 Views

Hello @Nawaf ,

 

Do you have the update regarding this issue and may I know what device and Quartus version are you using.

Looking forward to your reply and to make sure the issue can be solved. 

 

Best regards,

Nazrul Naim

 

0 Kudos
NazrulNaim_Intel
Employee
2,361 Views

Hello,

 

As we do not receive any response from you on the previous question/reply/answer that we have provided. Please login to ‘https://supporttickets.intel.com’, view details of the desire request, and post a feed/response within the next 15 days to allow me to continue to support you. After 15 days, this thread will be transitioned to community support. The community users will be able to help you on your follow-up questions.

 

Best regards,

Nazrul Naim


0 Kudos
Marco_Intel
Employee
1,952 Views

Please note that we released a patch that solves the bug in 23.1 Standard wrt to PLL GUI.

 

PATCH is available through the following KDB:
https://www.intel.com/content/www/us/en/support/programmable/articles/000098457.html

 

Best regards
Marco

0 Kudos
PrivateIsland
Beginner
1,802 Views

Hello Intel,

 

I installed the patch onto a 23.1 Quartus Lite install, and it fixed the PLL wizard.  However, Quartus now repeatedly prompts me to upgrade all the IP blocks even though they are all up to date. 

 

Please let us know if there is a fix for this and when we can expect a new version of Quartus Lite that doesn't require this patch.

 

Thank you. 

0 Kudos
Marco_Intel
Employee
1,752 Views
The patch was for Quartus Standard, not Lite version.

For Quartus Lite I do recommend to stay in 22.1.
0 Kudos
PrivateIsland
Beginner
1,720 Views

Thank you for the reply Marco.  

 

The patch in question was posted in reply to "Quartus Prime Lite 23.1 PLL Wizard Problem", and no errors were reported when applying the patch. 

 

Note that I had basically the same problem as reported by Nawaf.  When using the PLL IP MegaFunction wizard, the wizard would quit after screen 5 (of 12).   Applying the patch fixed the PLL problem, but it also seems to have created at least one new problem (continually prompting me to upgrade all IP blocks). 

 

Most likely we will want to reconfigure the parameters for the PLL using the Wizard.  Therefore, we need a stable 23.1 Lite version that supports creating PLLs.   Can Intel please create a patch for the Lite version? 

 

 

0 Kudos
Marco_Intel
Employee
1,655 Views

Hi,

 we verified installing in Quartus 23.1 Lite the patch released for Standard (later on called 23.1 Lite patched)

It successfully worked and fixed the PLL Issue as you reported.


Starting a new design from scratch in this 23.1 Lite patched, we do not see any issue with other IPs.
We did a test with Nios V /c + Embedded RAM and SPI.

In your case, did all IPs or some specific ones are continuously marked to need to be regenerated?
If some specific, can you please let me know which so that I can try to reproduce the issue?

If the issue is the upgrade only, have you tried to regenerate them from scratch instead of trying to upgrade them?


If you can attach the qar of the design I can have a look on my installation.
(if you can't no problem I can try to reproduce with the info asked above)


Thanks
Marco

0 Kudos
PrivateIsland
Beginner
1,584 Views

Hi Marco,

 

Thank you for the confirmation regarding the 23.1 Lite patch.  

 

It seems that the prompting to upgrade my IP components stopped after either rebooting the PC or maybe just closing out Quartus.   Regardless, I'm no longer seeing the issue.

 

However, I did discover that the same 23.1 Lite issue with PLL generation is also on the Linux version.   Is there a patch for Linux?

 

 

 

 

0 Kudos
Marco_Intel
Employee
1,535 Views

Hi PrivateIsland,

 thanks for confirming it.

 

Through the KDB listed above, you can find the patch for both Windows and Linux.

 

Best regards,
Marco

0 Kudos
Reply