Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
Announcements
The Intel sign-in experience is changing in February to support enhanced security controls. If you sign in, click here for more information.
15799 Discussions

Quartus can't start Fitter (can't load library error)

MHahn4
New Contributor I
1,219 Views

I have a problem with a Quartus Pro installtion:

 

Everytime I try to synthesis a project, the Fitter stage crashes with the following error:

 

Problem Details Error: Internal Error: Sub-system: ATCL, File: /quartus/ccl/atcl/atcl_root.cpp, Line: 987 ------------------------------------- Error found while sourcing: c:/intelfpga_pro/19.2/quartus/common/tcl/internal/init/fdrgn.pkg_info ------------------------------------- ERROR: Can't load library: c:\intelfpga_pro\19.2\quartus\bin64\fitter_fdrgn.dll. The operating system reports the following error: The specified module could not be found.     Stack Trace: 0x535d: err_report_internal_error + 0x2d (CCL_ERR) 0xfe33: atcl_initialize_pkg_info + 0x4e3 (ccl_atcl) 0x10dca: atcl_initialize_quartus_interpreter + 0xaa (ccl_atcl) 0xf742: atcl_get_interpreter + 0x42 (ccl_atcl) 0x2ddf6: ACF_MANAGER_STORAGE_REAL::ACF_MANAGER_STORAGE_REAL + 0x606 (db_acf) 0x2501d: ACF_MANAGER::internal_open_create_project + 0x7bd (db_acf) 0x2697d: ACF_MANAGER::open_project + 0x7bd (db_acf) 0xe1954: QHD_ROOT_IMPL::open_acf_if_needed + 0xc4 (comp_qhd) 0xe084e: QHD_ROOT_IMPL::initialize + 0x10e (comp_qhd) 0x17e73: QCU::DETAIL::initialise_qhd + 0xb3 (comp_qcu) 0x18028: QCU::DETAIL::initialise_qhd_and_perform_checks + 0x98 (comp_qcu) 0x1816c: QCU::DETAIL::intialise_qhd_and_run_qexe + 0x6c (comp_qcu) 0x290bc: qcu_run_tcl_option + 0x2ec (comp_qcu) 0x19c58: qexe_run + 0x438 (comp_qexe) 0x1ad8a: qexe_standard_main + 0x26a (comp_qexe) 0x2052: qfit2_main + 0x82 (quartus_fit) 0x14a08: msg_main_thread + 0x18 (CCL_MSG) 0x160ae: msg_thread_wrapper + 0x6e (CCL_MSG) 0x20fb0: mem_thread_wrapper + 0x70 (ccl_mem) 0x13f8d: msg_exe_main + 0x20d (CCL_MSG) 0x2918: __scrt_common_main_seh + 0x11c (quartus_fit) 0x17bd3: BaseThreadInitThunk + 0x13 (KERNEL32) 0x6cee0: RtlUserThreadStart + 0x20 (ntdll)   End-trace     Executable: quartus Comment: None   System Information Platform: windows64 OS name: Windows 10 OS version: 10.0   Quartus Prime Information Address bits: 64 Version: 19.2.0 Build: 57 Edition: Pro Edition

The file it can't load is where it should be.

 

What I've tried until now:

  • Reinstalled Quartus (using both direct download and Download Manager)
  • Installed it into another directory
  • Installed it on another drive
  • Excluted the Quartus directory in the anti virus software
  • Deactived the anti virus software

... but nothing helped ...

 

What else could I try to fix this?

 

Thanks

0 Kudos
1 Solution
2 Replies
MHahn4
New Contributor I
922 Views

Thank you very much!!! That solved the problem!

 

I had to install both (x64 and x86), because with the x64 alone Modelsim didn't want to start anymore. But now both are working fine.

Reply