Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
15796 Discussions

Questa Free license. License Assistant offline.

Thymo
Beginner
340 Views

Hi there,

 

I'm trying to generate a license for the free version of Questa supplied with Quartus Prime lite 21.1.

After searching for hours in the SSLC and this forum I have not been able to do so.

 

From my understanding it is required to log into the SSLC and use the license assistant in the bottom right of the screen to obtain a license. However I only see a minimized chat window indicating "Offline". I also tried the "Sign up for Evaluation or Free licenses" but this just gives me a message "No products available to sign up". The other windows under the licenses tab don't seem to allow me to download a license either.

 

I am dependant on Quartus through my university course. How can I best proceed to obtain a license for Questa?

0 Kudos
4 Replies
AR_A_Intel
Employee
320 Views

Hello

 

Welcome to Intel forum. You may request the Questa Sim Starter Edition free license here https://licensing.intel.com/       

1) Go to Sign up for Evaluation or Free licenses

2) Select Questa*-Intel® FPGA Starter Edition SW-QUESTA

3) # of Seats is always 1

4) Check the T&C box

5) Click Get License button

The license will be sent to email that you register with


Thymo
Beginner
303 Views

Hi,

 

Those were the steps that I initially tried and those didn't work when I first tried them. A day later I received an email that I could now manage and activate licenses. It was unclear this process would take about two days to complete.

I repeated the steps you described and was able to generate a license file that got emailed to me with a .dat extension. However, this license does not appear to be recognised by Questa. As instructed by the email containing the license: In Quartus go to "Tools > License setup", and check "Use LM_LICENSE_FILE variable". I set this variable to the path of the license file and rebooted to be sure. This does not appear to be working as vsim will indicate "Unable to checkout a license. Make sure your license file environment variable (e.g., LM_LICENSE_FILE)is set correctly and then run 'lmutil lmdiag' to diagnose the problem.Unable to checkout a license. Vsim is closing."

I tried running ./lmutil lmdiag and this does show the path to the license file as configured in the LM_LICENSE_FILE variable. It does not show any info about the license file itself, I'm not sure if this is supposed to be the case. I've inspected the license file itself and it appears to only contain ASCII text describing when the license was issued, for what machine, which features and when it expires. These lines are all prepended with a hash "#" suggesting they are comments. This gives me the feeling the license file does not contain all data required, but I may be wrong. I have removed personal information from the license file and attached it. Is this how the license file is supposed to look?

AR_A_Intel
Employee
285 Views

Hi

Regrettably, there are issue with Questa license generated recently. Could you help to apply again Questa license in Self Service Licensing Center https://licensing.intel.com/ any try it, see how things go.     


AR_A_Intel
Employee
259 Views

We have not heard from you and I hope that my last note clears up this matter and it can now be move forward. I will now transition this thread to community support. If you have a new question, feel free to open a new thread to get the support from Intel experts. Otherwise, the community users will continue to help you on this thread. Thank you.


Reply