Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)

Sdram error on DE2 - 35

Dolemy
Novice
1,524 Views

Hello.

I am learning about design through the DE2-35 board recently.

I used NIOS II processor to use sdram.

For this, I used the sdram controller ip and set it within my knowledge range.

There are settings and images related to it below.

I have completed the settings in Qsys and declared input and output and completed appropriate Pin assignment.

After completion, I programmed it on the FPGA board.

And to check if this setting is correct, I created a Memory Test template in Eclipse.

And I built it and confirmed that there was no error and programmed the software on the board. But the following error occurs. There is a picture below.

 

In addition, the following error message seems to be a specific problem.

 

/////////////////////////////////

0 [main] bash 37264 find_fast_cwd: WARNING: Couldn't compute FAST_CWD pointer. Please report this problem to
the public mailing list cygwin@cygwin.com
Using cable "USB-Blaster [USB-0]", device 1, instance 0x00
Processor is already paused
Initializing CPU cache (if present)
OK

Downloading 00200000 ( 0%)
Downloading 00210000 (90%)
Downloading 00211C14 (90%)
Downloaded 72KB in 0.8s (90.0KB/s)

Verifying 00200000 ( 0%)
Verify failed between address 0x200000 and 0x20FFFF


Leaving target processor paused

///////////////////////////////

 

when eclipse is verifying, it make error.

 

I don’t know why this problem is occurring at all.

Please let me know if you need any information.

Thank you for reading.

Dear doremi

0 Kudos
4 Replies
KellyJialin_Goh
Employee
1,469 Views

Hi,

Greetings and welcome to Intel's Forum.


This error message indicates that you are using an old cygwin on a newer windows version. You may download a newer cygwin version here: https://www.intel.com/content/www/us/en/docs/programmable/683187/20-1/installing-cygwin.html


Do take note that you have to remove your current old cygwin version to avoid errors and only remain one installation. If this issue continues to persist, you may need to contact the cygwin team.


Hope to hear on your feedback.


Thank you.

Regards,

Kelly


0 Kudos
KellyJialin_Goh
Employee
1,422 Views

Hi,

Any updates from you end whether the feedback provided is useful for you?

Have you tried downloading a later version of cygwin?


Thank you.

Regards,

Kelly


0 Kudos
Dolemy
Novice
1,406 Views

Thank you for your answer.

As you mentioned, I solved the cygwin problem. As a result, the cygwin error message in the above error message has been resolved.

However, there was still a problem downloading the elf file to the board.

but, I solved the problem as follows.

As you know, to use SDRAM, phase adjustment is required through PLL.

I set it up the same way as the tutorial, but the problem still occurred.

However, I declared two PLLs, one of which was inserted into Nios ii’s clk without changing the phase, and the other was given clk to SDRAM by changing the phase as before.

As a result, I was able to download the elf file to my DE2 board.

I still don’t know exactly why it was resolved.

However, I think that clock skew problem was solved through PLL and I was able to download it.”

 If people using Quartus 13.0 version see this answer, I would like to add the following information. If a cygwin error occurs, please refer to ftp://ftp.intel.com/Pub/fpgaup/pub/Cygwin_Patch/.

Your answer was really helpful.

 

0 Kudos
KellyJialin_Goh
Employee
1,375 Views

Hi,

I’m glad that your question has been addressed, I now transition this thread to community support. If you have a new question, Please login to ‘https://supporttickets.intel.com’, view details of the desire request, and post a feed/response within the next 15 days to allow me to continue to support you. After 15 days, this thread will be transitioned to community support. The community users will be able to help you on your follow-up questions.


p/s: If any answer from the community or Intel Support are helpful, please feel free to give best answer or rate 4/5 survey.

 

Thank you.


Regards,

Kelly Jialin, GOH


0 Kudos
Reply