Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
16704 Discussions

University Program VWF Simulations in Quartus Prime Lite 21.1 vs Quartus II 13.x

NTA
Novice
5,253 Views

Hello everyone,

 

I'm working on updating a university lab course from (old) Terasic DE1 boards and Quartus II 13.x to Terasic DE10-Lite boards and Quartus Prime Lite Edition 21.1.

 

While both software versions seem to be mostly identical, I can't get any simulations running. Everything else is working perfectly fine.

 

So far, the course has relied on the "University Program VWF Simulations" and the "Simulation Waveform Editor" for some very basic simulations. Is that no longer supported in Quartus 21.1?

In Quartus II there was an option for "Quartus II Simulator" in the simulation settings that needed to be selected, but I can't find anything comparable in Quartus Prime.

Since FPGAs are only one chapter of the entire course, we would like to keep it simple and therefore are hesitant to using the full version of Questa.

 

Where I'm currently stuck:

  • Quartus Prime Lite Edition 21.1 installed (and already reinstalled)
  • Extremely basic test project: Input (switch) -> NOT -> Output (LED)
  • Shortest possible file path for that project (no spaces or other special characters in file path)
  • "Questa - Intel FPGA Starter Edition 2021.2" is installed and linked to a local license
  • "Simulation Settings" are set to Default
  • Running the Functional/Timing Simulation leads to: "Error loading design"

Am I missing something?

 

Thank you all very much in advance!

 

Greetings from Germany,

NTA

 

 

 

0 Kudos
1 Solution
DrNickels
New Contributor I
5,221 Views

It still works.  Here is a video I made for my class showing a simple circuit.

The short of it is that you have to go to "simulation options" in the Simulation Waveform Editor and change vsim -novopt to vsim -voptargs="+acc".

View solution in original post

16 Replies
DrNickels
New Contributor I
5,222 Views

It still works.  Here is a video I made for my class showing a simple circuit.

The short of it is that you have to go to "simulation options" in the Simulation Waveform Editor and change vsim -novopt to vsim -voptargs="+acc".

NTA
Novice
5,214 Views

Thank you so very much!

 

I had almost given up on this feature.

0 Kudos
elgarbe
Beginner
4,125 Views
0 Kudos
Ash_R_Intel
Employee
5,180 Views

Hi,

I see that the case already has an accepted solution. Do you need any further support on this?


Regards


0 Kudos
NTA
Novice
5,173 Views

Hello,

thanks for asking, but the issue could be resolved with the instructions provided by DrNickels.

 

I'm just curious how that bug has gone unnoticed by Intel for so long.

0 Kudos
Ash_R_Intel
Employee
5,120 Views

Hi,

The -novopt option is being deprecated in recent Questasim versions. So, that cause the issue.


Regards


sstrell
Honored Contributor III
5,107 Views

Any idea how in the Questasim GUI to remove -novopt when compiling?  I understand the change mentioned above for starting the simulation (vsim) but I still see -novopt when compiling (vlog) and get errors from it.

0 Kudos
DrNickels
New Contributor I
5,103 Views

It's in the Simulation/Simulation Settings window in the GUI.

Capture.JPG

 

Capture.JPG

0 Kudos
sstrell
Honored Contributor III
5,101 Views

No, I was talking about in Questasim.

0 Kudos
DrNickels
New Contributor I
5,039 Views

Ah.  Sorry for misunderstanding.  It is confusing that the simulator labelled "Simulation Waveform Editor" is called "vsim".

When I use a testbench in Quartus and call Questa (Intel FPGA Starter Edition - not sure if that's different from "Questasim") from there, I get the correct flags, so can't offer any help there. 

0 Kudos
NTA
Novice
5,031 Views

Just to add to the topic, as this piece of information might be useful to someone:

The Max10-FPGA is not supported for Timing Simulations (neither is the Cyclone V). However, when selecting any CycloneIV model the Timing Simulation does work perfectly fine.

0 Kudos
Ash_R_Intel
Employee
5,020 Views

Hi @sstrell,

The IP generated simulation script offer 2 aliases: ld and ld_debug.

ld_debug has the -voptargs=+acc option to the vsim command. Once the script is sourced, you can choose to use the ld_debug alias to start elaboration.


Hope this helps.


Regards


0 Kudos
sstrell
Honored Contributor III
5,007 Views

I'm not talking about generated scripts.  I'm talking about going to Questasim, setting the directory to the location of the design files, and compiling the files from the Compile menu.

0 Kudos
Ash_R_Intel
Employee
4,705 Views

Hi,

I think older QuetaSim simulator had an option 'Enable Optimization' when you do 'Start Simulation'. But in newer version, the option has been removed. So, if someone wants to migrate from older versions to newer, they need to drop the option -novopt from vsim command.


Regards


0 Kudos
Ash_R_Intel
Employee
4,546 Views

Hi,

As the queries has been answered, setting the case to closure. However, it will still be open for community members to comment.


Regards


0 Kudos
NTA
Novice
3,901 Views

Summary of how to run University Program VWF Simulations in Quartus Prime

Having done quite a bit of testing with various versions of Quartus Prime, here's a list of the necessary steps to get University Program VWF Simulations running in the different versions:

 

  • Quartus Prime 18.1 and 19.1:
    1. .vwf file should be stored in project directory (not in output_files); no special characters (including spaces and -) in file path
    2. In the waveform editor under Simulation -> Simulation Settings, hit Restore Defaults to initialize all file paths correctly

  • Quartus Prime 20.1 and 20.1.1:
    1. .vwf file should be stored in project directory (not in output_files); no special characters (including spaces and -) in file path
    2. In the waveform editor under Simulation -> Simulation Settings, hit Restore Defaults to initialize all file paths correctly
    3. The ModelSim Script (Simulation -> Simulation Settings) needs to be changed in both tabs (Functional and Timing Simulation) individually: Remove the -novopt from line 5

  • Quartus Prime 21.1 and 21.1.1
    1. Generate a license for Questa and link it to your installation (tutorial on youtube: youtube.com/watch?v=F6FvXga4f1A)
    2. .vwf file should be stored in project directory (not in output_files); no special characters (including spaces and -) in file path
    3. In the waveform editor under Simulation -> Simulation Settings, hit Restore Defaults to initialize all file paths correctly
    4. The ModelSim Script (Simulation -> Simulation Settings) needs to be changed in both tabs (Functional and Timing Simulation) individually: Change the -novopt in line 5 to -voptargs="+acc"

  • Quartus Prime 22.1
    1. (Unkown)

 

Timing Simulations:

Not all FPGAs are supported for Timing Simulations (Functional and Timing simulation show identical results). For example, the MAX10 on the DE10-Lite Board that we use for our lab course isn't supported. However, for demonstration purposes the project's FPGA can be changed to any Cyclone IV model (make sure the Cyclone IV family has been installed). Be aware that his will delete all pin assignments! Afterwards, the project can be recompiled and in the Waveform Editor the Simulation Settings must be reinitialized by hitting Restore Defaults (Simulation -> Simulation Settings -> Timing Simulation). Since the last step overwrites all the changes that were made to the ModelSim Script, those have to be made again as described above (Quartus Prime 20.1 and newer).

 

Should anyone find a way to use Quartus Prime 22.1, feel free to add instructions to this list.

Thanks to anyone who contributed to the list by sharing their knowledge!

0 Kudos
Reply