Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
15544 Discussions

Unrecognized compilation error

TaySpen
Novice
1,574 Views

I recently installed a fresh version of Quartus Prime Lite 18.1 on Linux. I have a Cyclone 10LP development kit and am trying to compile one of the example projects included. I have compiled the same project on a previous install so I know it works. No other warnings.

I am getting an error from the EDA Netlist Writer:

 

Error (20268): Functional simulation is off but it is the only supported netlist type for this device.

 

I have never modified any netlist types and haven't found any info online or looking through some Quartus manuals or through the software.

 

All suggestions and feedback are appreciated. Thanks

 

3 Replies
TaySpen
Novice
546 Views

Update: I have continued searching and have found a documented list of a deeper explanation of all the error codes produced by the standard Quartus synthesis process. Error code 20268 is not listed.

 

https://www.intel.com/content/www/us/en/programmable/quartushelp/current/index.htm#msgs/msgs/msgs.ht...

Vicky1
Employee
546 Views
Hi, I tried to replicate the issue & I observed same behavior for windows & Linux platform for Quartus 18.1 lite but It worked for Quartus 18.0 lite on both platform. Please,try to perform the 'EDA Netlist Writer' after deleting 'db' and 'Incremental_db' directory from project directory. Regards, Vikas
TaySpen
Novice
546 Views

Vicky,

Thanks for the suggestion. I removed the db and incremental_db directories and attempted a recompile and received the same results.

I will try to roll back to 18.0 to see if it is an update issue.

 

Thanks,

 

-Taylor

 

** Update: The same program will compile as expected on v18.0. I will continue using v18.0 until I see something about it in a future release.

Reply