Community
cancel
Showing results for 
Search instead for 
Did you mean: 
EHepl
Beginner
642 Views

Using Quartus 19.1 Lite on Windows 10 - Platform Designer failed when executing "Generate HDL". Appears that command "wsl" is missing?

Trying to "Generate HDL".  No errors reported while constructing system in platform designer GUI, but when "Generate HDL" button pressed, errors appear.  Please see attached "log".  Appears to be looking for "wsl" command.  Suggests using "apt" to install, even though this is a Windows 10 system.

0 Kudos
7 Replies
EHepl
Beginner
534 Views

Attached log file...

EHepl
Beginner
534 Views

Looks like "wsl" is Windows Subsystem for Linux. It is installed on my Windows system... and will execute in a powershell. When using it via Bash Ubuntu on Windows, it is version 18.04 of Ubuntu.

534 Views

Could you try to reinstall again with the installation procedure from the user guide?

Let me know if it solves the issue.

 

The procedure for installing WSL:

1. Go to https://docs.microsoft.com/en-us/windows/wsl/install-win10 and follow Microsoft*'s instructions to install Ubuntu 18.04 LTS for WSL.

Note: Windows 10 build version 16215.0 or higher is the recommended operating system version.

2. After installation has successfully completed, launch Ubuntu 18.04.

3. Install additional distro packages required for Nios II EDS using the following commands:

  • sudo apt install wsl
  • sudo apt install dos2unix sudo apt install make

 

Reference: https://www.intel.com/content/dam/www/programmable/us/en/pdfs/literature/manual/quartus_install.pdf#...

EHepl
Beginner
534 Views

Looks like my other "comment" to this posting isn't here...

I already have "wsl" on my Windows 10 machine. I've been using it for years (but didn't recognize it as "wsl" since I think of it as Bash for Windows or Ubuntu). It is running Ubuntu 18.04

It already has the "up-to-date" version of dos2unix and make (reported when doing the apt install), but I didn't realize that I needed to add "wsl" on the Ubuntu side. That has now been done.

 

My other post also mentioned that this .qsys file works in Quartus Prime Lite version 18.1, but doesn't work in Quartus Prime Lite version 19.1

 

After adding "wsl", I tried again to "Generate HDL" on the same .qsys file using Quartus 19.1, and still have the problem. I uploaded a screen capture of the issue. Claims it can't generate IP in a windows environment.

 

Are some of the tools in the 19.1 distribution "Linux only"?

 

534 Views

After checking, it seems there is an issue starting with the Quartus in window version 19.1 when generating any EMIF IP or Cyclone® V/Arria® V HPS IP in qsys. "FATAL: Cannot generate IP in a Windows evironment!"

KDB link: https://www.intel.com/content/altera-www/global/en_us/index/support/support-resources/knowledge-base...

 

Unfortunately the patch is only available for Quartus Standard Edition, I would recommend to use back Quartus 18.1 Lite Edition for now or Quartus19.1 Standard Edition with the patch installed. The Quartus linux version seems to be not impacted. Until then, please wait for the Quartus v20.1 Lite Edition release (probably in Q3/Q4) and hopefully that the issue has been solved.

Rafal
Employee
491 Views

I had the same issue. I did 3 things before I started working with Q19:

#1 enabling WSL in Win 10

Install WSL (Windows Subsystem for Linuxs), in Power Shell (as administrator) execute:

dism.exe /online /enable-feature /featurename:Microsoft-Windows-Subsystem-Linux /all /norestart

and Reboot PC

 

#2 install Ubuntu in Windows environment, run power shell as admin and:

i) Invoke-WebRequest -Uri https://aka.ms/wsl-ubuntu-2004 -OutFile Ubuntu.appx -UseBasicParsing
ii) Add-AppxPackage .\Ubuntu.appx

Next, from menu start run "Ubuntu"

 

After this step, you should have console with Ubuntu session. You can open new window by running "Ubuntu" from Menu start. This is Ubuntu, so you can download any package as you need.

 

#3 install additional package in Ubuntu:

 

sudo apt update

sudo apt install wsl

 

*remark - remember about proxy. If your network requires special settings, please apply them in your Ubuntu session (/etc/apt/apt.conf.d/)

 

After all of theses step I could use my quartus in Windows.

 

 

#2 

Rafal
Employee
480 Views

if Invoke-WebRequest -Uri https://aka.ms/wsl-ubuntu-2004 -OutFile Ubuntu.appx -UseBasicParsing will not work, please replace version and try

 

Invoke-WebRequest -Uri https://aka.ms/wsl-ubuntu-1804 -OutFile Ubuntu.appx -UseBasicParsing

Reply