Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
Announcements
All support for Intel NUC 7 - 13 systems has transitioned to ASUS. Read latest update.
16499 Discussions

Will not read EPM7128S

Maxcat800
Beginner
778 Views

When I write to a EPM7128s everything works great, it writes and verify the file. I have the security bit off. Why will it not let me read or examine the chip? It will not even let me select the examine function. Is there something I need to do differently when reading? I'm using a USB blaster with Quartus II 13.1 version.

Labels (1)
0 Kudos
8 Replies
_AK6DN_
Valued Contributor I
766 Views

Examine/read was deprecated by Altera around the Quartus 11 to 13 timeframe. Program/verify/blank check work. Examine does not.

They removed the feature by QuartusII 13.0sp1. No reason was given, it was just removed. So you cannot read the device program.

Note this was specific to the MAX EPM3k and EPM7k series. Other parts like CycloneII etc can be both written and read back.

You can program and then verify. If you can do that you have by default the current program file of the device.

But if you have some random MAX device and you want to examine/read the device program (eg, to copy to another device) you are out of luck.

I have an earlier installs of QuartusII 6.1/9.1sp2/13.0sp1 and it does allow read/examine of the EPM3xxxS and EPM7xxxS series parts and saving the contents to a file, using a USB Blaster.

A third party programmer would also likely be able to read the device program. I can do this on my EEtools TopMaxII.

Maxcat800
Beginner
716 Views

I installed Quartus II 9.1sp2 and still no luck with reading the device.  I can write and verify the file and the security bit is off. 

0 Kudos
_AK6DN_
Valued Contributor I
702 Views

Looks like you are right.

I had based my earlier answer on my tests using an EPM3064A and EPM7064S devices using QuartusII Web 9.0sp2.
I have development boards with those devices and QuartusII Web 13.0sp1 cannot examine them, but QuartusII Web 9.0sp2 can.
For each of those devices I could read/examine the device program to a file, and then use that file to verify the program.

So I (wrongly, it appears) extrapolated the functionality to the EPM7128S device.

I pulled out my EPM7128S development board, and lo and behold examine is not enabled (no checkbox capability) in
either of QuartusII Web 13.0sp1 (expected), but NOT present in either QuartusII Web 9.0sp2 or QuartusII Web 6.1. The
examine (and erase) check boxes are disabled for the EPM7128S across the board in all tested versions.

So it appears that the correct answer is there is partial capability for examine of EPM3xxxA and EPM7xxxS devices in earlier
Quartus versions. I don't have access to any Quartus versions prior to 6.1 nor do I have any MaxPlusII versions.

So the exact Quartus version that stopped being able to examine an EPM7128S will remain a mystery for now.

Ok lets start all over again and redo all the tests I can do from scratch instead of relying on partial memory.

I have QuartusII 13.0sp1, 9.1sp2, and 6.1 available.

I have boards with an EPM3064A, an EPM7064S, and an EPM7128S available.

Trying all the combinations of boards and program/verify/examine functionality I get this matrix.

 3064A7064S7128S
QuartusII 6.1program/verify/examine/eraseprogram/verifyprogram/verify
QuartusII 9.1sp2program/verify/examine/eraseprogram/verifyprogram/verify
QuartusII 13.0sp1program/verify/examine/eraseprogram/verifyprogram/verify


So as can be seen ONLY the EPM3064A supports the examine feature in QuartusII versions I tested.
Neither of the EPM7064S nor EPM7128S support the examine feature in any of those versions.

I can't say about earlier Quartus versions as I don't have those anymore (6.1 is from 2006). At some point I suspect
Quartus supported the examine function for the EPM7nnnS parts but I can't say when based on the tools I have available.

0 Kudos
Maxcat800
Beginner
598 Views

I tried version 2.1, 2.2, 4.1, 4.2, 5.0 and 5.1. Examine/read function disabled on all of them for EPM7nnnS parts. I don't know if this function ever was enabled or the versions, I found online have been updated to not allow this function. 

0 Kudos
_AK6DN_
Valued Contributor I
588 Views

Truthfully I am not surprised that is what you found, that EXAMINE is not enabled for EPM7xxxS for any version of QuartusII.
I can say I have never needed to do an EXAMINE.
I certainly have used PROGRAM and VERIFY routinely over the years.
BLANK CHECK hardly ever, usually just reprogram and verify.

My observation is that folks wanting to do an EXAMINE typically have some piece of hardware that they don't have the
original program image for, and they either want to reverse engineer it, or attempt to copy it to program a replacement chip.

These days replacing an EPM7xxxS (out of production) with an ATF15xx (still in production) can be done using
the POF2JED tool from MicroChip, but these requires the original .pof programming file, or the one read out of the device
using the EXAMINE function. I have used POF2JED with the Quartus generated .pof file, but never with one extracted from a device.

These days using a legacy third party device programmer (Xeltek, EEtools, etc) is probably the only mechanism to read
the contents of an EPM7xxx/A/B/S series device, as those programmers use the parallel programming access method, and
do not use the JTAG interface.

0 Kudos
FvM
Valued Contributor III
735 Views

_AK6DN_, thanks for the detailed explanation.

I felt you were definitely wrong when you wrote in a recent post, examine doesn't work with Quartus at all because I'm quite sure to have used it time ago. But I surely used Quartus V9 or older. Now things make sense.


0 Kudos
NurAiman_M_Intel
Employee
570 Views

Hi,


Examine feature is not supported for MAX7000.


But you can refer to our old community post that has similar issue. Perhaps you can get some idea:

https://community.intel.com/t5/Programmable-Devices/Extract-programming-file-from-Altera-EPLD/td-p/137752?profile.language=es&countrylabel=Argentina


Regards,

Aiman


0 Kudos
NurAiman_M_Intel
Employee
299 Views

We do not receive any response from you to the previous answer that I have provided. This thread will be transitioned to community support. If you have a new question, feel free to open a new thread to get the support from Intel experts. Otherwise, the community users will continue to help you on this thread. Thank you


0 Kudos
Reply