Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
940 Views

program failed, can't load driver for OpenCL RTE , DE1 SoC

Hi -- I'm trying to run the hello_world example from http://www.terasic.com.tw/attachment...opencl_v02.pdf (http://www.terasic.com.tw/attachment/archive/836/de1soc_opencl_v02.pdf

However when I type 'aoc program hello_world.aocx' it throws following error: 

aocl program: Running reprogram from /home/root/opencl_arm32_rte/board/c5soc/arm32/bin 

Couldn't open /dev/ac10 device! Did you load the driver? 

aocl program: Program failed. 

https://alteraforum.com/forum/attachment.php?attachmentid=13572&stc=1  

 

 

But I can find the driver in that folder. 

 

 

Initializing OpenCL  

Platform: Altera SDK for OpenCL  

Using 1 device(s)  

de1soc_sharedonly : Cyclone V SoC Development Kit  

Using AOCX: vectorAdd.aocx  

ERROR: can't load drive 

Failed program
0 Kudos
4 Replies
Altera_Forum
Honored Contributor I
137 Views

Moving to the OpenCL forum so that the right people see this.

Altera_Forum
Honored Contributor I
137 Views

@moningWYL, did you read terasic's opencl manual (http://www.terasic.com.tw/attachment/archive/836/de1soc_opencl_v02.pdf)? It has step-by-step instructions as to how you can run the hello_world and vector_add examples. You probably didn't run the "source ./init_opencl.sh" command to set up the environment and load the kernel driver.

Altera_Forum
Honored Contributor I
137 Views

Thanks a lot!

Altera_Forum
Honored Contributor I
137 Views

Yes ,I read it,and I run the vector_add examples following DE1SOC_OpenCL_v02.pdf.

Reply