Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
16728 Discussions

quartus_cpf.exe does not work with database error

TKudoh
Beginner
1,546 Views

I'm trying to convert programing file in the command line,
but quartus_cpf.exe (quartus 18.1) finishes with the errors.

Looking at the errors, it seems that the database version does not match.

What should I do?

 

Conversion setup data (.cof) is created with Convert Programming File tool (GUI),
and it works correctly in this GUI tool.

 

The Error messages are  below.

It has same result when quartus_cps is run in Windows10 command shell (cmd.exe) 
or Nios II command shell. 

 

$ quartus_cpf -c makejic.cof

Info: *******************************************************************
Info: Running Quartus Prime Convert_programming_file
Info: Version 18.1.2 Build 277 02/12/2019 SJ Pro Edition
Info: Copyright (C) 2019 Intel Corporation. All rights reserved.
Info: Your use of Intel Corporation's design tools, logic functions
Info: and other software and tools, and any partner logic
Info: functions, and any output files from any of the foregoing
Info: (including device programming or simulation files), and any
Info: associated documentation or information are expressly subject
Info: to the terms and conditions of the Intel Program License
Info: Subscription Agreement, the Intel Quartus Prime License Agreement,
Info: the Intel FPGA IP License Agreement, or other applicable license
Info: agreement, including, without limitation, that your use is for
Info: the sole purpose of programming logic devices manufactured by
Info: Intel and sold by Intel or its authorized distributors. Please
Info: refer to the applicable agreement for further details, at
Info: https://fpgasoftware.intel.com/eula.
Info: Processing started: Wed Jun 21 12:11:34 2023
Info: Command: quartus_cpf -c makejic.cof
Error (114006): Database file c:/intelfpga_pro/18.1/quartus/common/devinfo/20nm/ddb_nightfury_info.ddb, created by Quart
us II Version 18.1.0 Build 222 09/21/2018 SJ Pro Edition software, not compatible with current Quartus Prime Version 18.
1.2 Build 277 02/12/2019 SJ Pro Edition software
Error (114006): Database file c:/intelfpga_pro/18.1/quartus/common/devinfo/20nm/ddb_nightfury_info.ddb, created by Quart
us II Version 18.1.0 Build 222 09/21/2018 SJ Pro Edition software, not compatible with current Quartus Prime Version 18.
1.2 Build 277 02/12/2019 SJ Pro Edition software

Labels (1)
0 Kudos
8 Replies
Farabi
Employee
1,511 Views

Hi,


can you try latest version of Quartus did it show same error?


regards,

Farabi


0 Kudos
FvM
Valued Contributor III
1,502 Views

Hello,

looks like you have multiple Quartus installations (18.1.0 Pro and 18.1.2 Pro) on your computer and inconsistent path and Quartus enviroment variables. This causes problems particularly when running tools from the command shell.

Possible solution, fix the enviroment variables to point to your latest Quartus installation.

0 Kudos
TKudoh
Beginner
1,457 Views

Hi,

First I installed Quartus pro 18.1.0, and then installed 18.1.2 update patch.

 I remember installing with default settings... Is it the installer problem?

I will test in another machine.

 

Regards,

Kudoh

0 Kudos
NazrulNaim_Intel
Employee
1,330 Views

Hi,

 

It has been a while since you posted an update to this case. Do you have any updates for me? If you do not have further inquiries, I would like to put this case in close-pending status.


Regards,

Nazrul Naim


0 Kudos
TKudoh
Beginner
1,323 Views

Hi,

I tried it on another PC and it worked.
And I tried the standalone version of the programmer instead of the full set Quartus Pro and it worked on my PC, too.

 

The difference between my PC and another PC is the Arria 10 license, and my PC does not have a license installed (because I am only developing firmware). Could this be the cause?

 

Regards,

Kudoh

0 Kudos
NazrulNaim_Intel
Employee
1,303 Views

Hello,


Generally, Yes. The license version will have access to specific features for Arria10.


Hope that answers your question


Best regards,

Nazrul Naim


0 Kudos
TKudoh
Beginner
1,289 Views

Hi,

However, if it's a licensing issue, I don't see why the GUI version programmer would work.
For the time being, I solved it by using the standalone version, so I will close this topic.

 

Regards,

Kudoh

0 Kudos
NazrulNaim_Intel
Employee
1,259 Views

Hello,

 

I’m glad that your question has been addressed, for now I will set this case to Close-Pending. 

 

Regards,

Nazrul Naim



0 Kudos
Reply