Community
cancel
Showing results for 
Search instead for 
Did you mean: 
xgiaime
Novice
366 Views

"Use smart compilation" is greyed out

Dear all,

 

I'm using Quartus Prime Lite Edition 18.1, however the issue persists also with 18.0. The "Use smart compilation" is greyed out and cannot be enabled.

 

Is this a device-dependent thing? My project has a MAX10.

Is this a license-dependent thing?

 

It would be helpful to have smart compilation, as Quartus asks me to re-do analysis/synthesis/fitting even if I just change a value in a memory initialization file (even if the file I'm editing is not belonging to the project!!!).

 

Thanks in advance

0 Kudos
4 Replies
Vicky1
Employee
141 Views

Hi,

To turn on smart compilation, on the Assignments menu, click Settings. In the Category list, select Compilation Process Settings and turn on Use smart compilation.

https://www.intel.com/content/dam/www/programmable/us/en/pdfs/literature/hb/qts/qts_qii52022.pdf

please let me know if you have any different concern & refer below screenshot,

smart_comp.JPGRegards,

Vicky

 

xgiaime
Novice
141 Views

Dear Vicky,

 

as you can see from the image attached, the option is greyed out.

I tried to create a blank project with multiple devices in the MAX10 family, and the option is always greyed out.

When I create a blank project with a Cyclone device, the option is available.

 

Bug? Intentional limitation?

ak6dn
Valued Contributor II
141 Views

My observation is it is not supported for the MAX series devices as they are 'too small' for it to matter. Cyclone and up devices support the feature. YMMV.

Vicky1
Employee
141 Views

Hi,

I believe it`s device dependent but there is no enough information available for devices support details except Arria 10 devices are not supported(Quartus Pro User guide).

https://www.intel.com/content/www/us/en/programmable/quartushelp/current/index.htm#msgs/msgs/wflow_s...

Regards,

Vicky

Reply