Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
15679 Discussions

set get_device_family [get_parameter_value DEVICE_FAMILY]

MingBai
Beginner
360 Views
Dear,
 
I can't get the device by calling get_parameter_value  .
What's Wrong ?
 
The code is as follows:
 
proc elaboration_callback {} {
    set get_device_family [get_parameter_value DEVICE_FAMILY]
}
 
mingcan_0-1639134953694.png

 

0 Kudos
1 Solution
ShengN_Intel
Employee
285 Views

Hi mingcan,

 

ShengN_Intel_0-1639404969401.png

ShengN_Intel_1-1639405116807.png

I tried with simple tcl script of device_family and it worked well.

package require -exact qsys 15.0 (14.0 and 16.0 both also worked)

Quartus lite version 21.1

 

View solution in original post

6 Replies
ShengN_Intel
Employee
330 Views

Hi mingcan,

 

Try to use command 'get_project_property' instead of 'get_parameter_value'. The error still persist?

 

Best Regards,
Sheng

p/s: If any answer from the community or Intel support are helpful, please feel free to give Kudos.

ShengN_Intel
Employee
324 Views

Invalid command name ''elaboration_callback'' most probably due to not being enabled. Should be first enabled with -  set_module_property ELABORATION_CALLBACK elaboration_callback. Can refer manual below page 26.

https://www.intel.com/content/dam/www/programmable/us/en/pdfs/literature/hb/qts/qsys_components.pdf 

MingBai
Beginner
314 Views

Dear,

 

       I've confirmed that "elaboration_callback" is enableed.
The format of my script is similar to the example in the manual below page 26.
"get_project_property" work not well.
I want to get fpga device by tcl script.
ShengN_Intel
Employee
286 Views

Hi mingcan,

 

ShengN_Intel_0-1639404969401.png

ShengN_Intel_1-1639405116807.png

I tried with simple tcl script of device_family and it worked well.

package require -exact qsys 15.0 (14.0 and 16.0 both also worked)

Quartus lite version 21.1

 

MingBai
Beginner
256 Views

Dear,

        Thank you very much.

I hope more FPGAer will see this topic.

ShengN_Intel
Employee
251 Views

Hi mingcan,

 

I’m glad that your question has been resolved. 

 

I now transition this thread to community support. If you have a new question, feel free to open a new thread to get the support from Intel experts. Otherwise, the community users will continue to help you on this thread. Thank you.

 

Best Regards,
Sheng

p/s: If any answer from the community or Intel support are helpful, please feel free to give Kudos.

Reply