Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
15481 Discussions

unable to reuse design partition in quartus 19.3 version.

DChak3
Beginner
294 Views

Hi It seems there is an issue to reuse the design partition in quartus 19.3 version.

As while using the .qdb file it takes the file. But in netlist viewer I am unable to see the design connected. I have generated and reused .qdb file many times in 18.2 version but never faced this issue. I am not sure is any thing more need to be done in the latest version.

Also while reusing the design I am not able to see "set as design partition" in the window. which was available in 18 version.

 

 

 

0 Kudos
6 Replies
KhaiChein_Y_Intel
167 Views

Hi,

 

Could you share the error message?

 

Thanks.

DChak3
Beginner
167 Views

hi

 

Its not the error. Instead the .qdb file is not getting connected if seen in the rtl viewer.

Here are the steps which I followed.

  1. Create a project add all the rtl files. Run analysis and synthesis once.
  2. In the hieracrchy tab the module which I need to create a partition, right click it go to design partition, select default.
  3. Run synthesis again, once done. Go to projects > export design partion> export the synthesised snapshot of the module.

To resue:

  1. create a project with top file and the resuse module stub file.
  2. run synthesis once.
  3. follow the step no. 2 above to set the module to default.
  4. int he desin partion window add the .qdb file and run the synthesis again

these steps I followed for Quartus 18. which was perfectly reusign the design. But here seems some issue with the .qdb file.

 

Added scrrenshots.

I have double checked there is no issue with the stub file, I am using all signals are same. I also tried running the whole flow till fitter but the results are same. As you can see once I add the qdb file. It is not getting connected to the design.

 

 

DChak3
Beginner
167 Views

Here are more screen shots

  1. this the rtl view before qdb. only the top file and the partitioned stub file.

rtl_view_before_qdb.PNG

 

2. this the rtl view after adding the qdb

 

rtl_view_after_qdb_file.PNG

so u can see the partitioned files are not getting connected. The same procedure I gave done with quartus 18. There was no any issue. But here I can see that. Is there any thing I am missing.

KhaiChein_Y_Intel
167 Views

Hi,

 

Can you provide the design and steps to reproduce the error?

 

Thanks.

DChak3
Beginner
167 Views

Hi

 

Thanks for response. It seems the problem was from my side in top level file. It resolves now.

KhaiChein_Y_Intel
167 Views

Hi,

 

It is glad that you found the root cause.

 

Thanks

Reply