Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
16652 Discussions

use the -2008 switch to vcom to unable(vcom-1436)

keiengineer
Beginner
955 Views

error 

 

vcom Message # 1436:
# VHDL 1993 through VHDL 2002 allowed an expression to be associated with
# a formal port in a port map as long as the expression was globally
# static and the port was of mode IN. VHDL 2008 now allows non-static
# expressions as well. Use the -2008 switch to vcom to enable this
# feature.

 

How can I switch to -2008?

0 Kudos
4 Replies
ShengN_Intel
Employee
926 Views

Hi,


You can do like this vcom -2008 <your_file.vhd>

Or you can edit the modelsim.ini by doing this VHDL93 = 3 / 2008


Best Regards,

Sheng


p/s: If any answer from community or Intel support are helpful, please feel free to mark as solution and give Kudos.


0 Kudos
ShengN_Intel
Employee
911 Views

Hi,

 

Modelsim or Questa:

Compile > Compile Options > VHDL > Use 1076-2008

Right clicking on the files > Properties > Project Compiler Settings > VHDL > Language Syntax > Use 1076-2008

Nativelink:

Go to [ Settings | Compiler Settings | VHDL Input ] and select [ VHDL 2008 ]

 

Best Regards,

Sheng

 

p/s: If any answer from community or Intel support are helpful, please feel free to mark as solution and give Kudos.

 

0 Kudos
ShengN_Intel
Employee
891 Views

Any further consideration on this thread?


0 Kudos
ShengN_Intel
Employee
867 Views

Since there are no further feedback for this thread, I shall set this thread to close pending. If you still need further assistance, you are welcome reopen this thread within 20days or open a new thread, some one will be right with you.


0 Kudos
Reply