Intel® SoC FPGA Embedded Development Suite
Support for SoC FPGA Software Development, SoC FPGA HPS Architecture, HPS SoC Boot and Configuration, Operating Systems
461 Discussions

Error occurred when build the u-boot

Rainwang
New Contributor II
3,106 Views

i have a10 dev kit on hand, and i would like to build a bare metal project per the instructions  in below link (https://rocketboards.org/foswiki/Documentation/SoCEDS#Arria_10_Bare_Metal_Example_Using_SoC_EDS_Pro_Edition)step by step.

but error happened when i run below step:

make socfpga_arria10_defconfig

i attached all my command and response which i copied from the embedded comand shell for your reference, please tell me how to resolve it, thanks.

0 Kudos
1 Solution
Rainwang
New Contributor II
2,850 Views

it seemed work today.

in fact , i was looking for the solution to support the usb blaster under WSL2, what i did is as below:

1. My platform: WSL2 + ubuntu 18.04 on windows 10

2. to support USB blaster on WSL2, i upgraded the linux kernel from 5.10.16.3 to 5.10.60.1.

3. checked the specification Intel® FPGA Software Installation and Licensing, found some dependencies need to be installed.

from /var/log/dpkg.log, i upgraded below packages, not sure which one is root cause

at last, the usb blaster still can't work on ubuntu, but i found the u-boot now can be made successfully. 

---------------------------------------------------------------------------------------

2022-08-17 14:57:23 install liblzma-dev:amd64 <none> 5.2.2-1.3ubuntu0.1
2022-08-17 15:27:33 install lib32tinfo5:amd64 <none> 6.1-1ubuntu1.18.04
2022-08-17 15:27:33 install lib32ncurses5:amd64 <none> 6.1-1ubuntu1.18.04
2022-08-17 15:42:05 install zlib1g-dev:amd64 <none> 1:1.2.11.dfsg-0ubuntu2.1
2022-08-17 15:57:17 install libtinfo-dev:amd64 <none> 6.1-1ubuntu1.18.04
2022-08-17 15:57:17 install libncurses5-dev:amd64 <none> 6.1-1ubuntu1.18.04
2022-08-17 15:57:17 install u-boot-tools:amd64 <none> 2020.10+dfsg-1ubuntu0~18.04.2
2022-08-17 15:57:17 install device-tree-compiler:amd64 <none> 1.4.5-3
2022-08-17 15:57:17 install libattr1-dev:amd64 <none> 1:2.4.47-2build1
2022-08-17 15:57:17 install libacl1-dev:amd64 <none> 2.2.52-3build1
2022-08-17 15:57:17 install uuid-dev:amd64 <none> 2.31.1-0.4ubuntu3.7
2022-08-17 16:06:50 install libdouble-conversion1:amd64 <none> 2.0.1-4ubuntu1
2022-08-17 16:06:50 install libqt5core5a:amd64 <none> 5.9.5+dfsg-0ubuntu2.6
2022-08-17 16:06:50 install libqt5dbus5:amd64 <none> 5.9.5+dfsg-0ubuntu2.6
2022-08-17 16:06:50 install libqt5network5:amd64 <none> 5.9.5+dfsg-0ubuntu2.6
2022-08-17 16:06:51 install libqt5qml5:amd64 <none> 5.9.5-0ubuntu1.1
2022-08-17 16:06:51 install qttranslations5-l10n:all <none> 5.9.5-0ubuntu1
2022-08-17 16:10:21 install libc6-dev-i386:amd64 <none> 2.27-3ubuntu1.6
2022-08-17 16:10:21 install libc6-x32:amd64 <none> 2.27-3ubuntu1.6
2022-08-17 16:10:21 install libc6-dev-x32:amd64 <none> 2.27-3ubuntu1.6
2022-08-17 16:10:22 install libx32gcc1:amd64 <none> 1:8.4.0-1ubuntu1~18.04
2022-08-17 16:10:22 install lib32gomp1:amd64 <none> 8.4.0-1ubuntu1~18.04
2022-08-17 16:10:22 install libx32gomp1:amd64 <none> 8.4.0-1ubuntu1~18.04
2022-08-17 16:10:22 install lib32itm1:amd64 <none> 8.4.0-1ubuntu1~18.04
2022-08-17 16:10:22 install libx32itm1:amd64 <none> 8.4.0-1ubuntu1~18.04
2022-08-17 16:10:22 install lib32atomic1:amd64 <none> 8.4.0-1ubuntu1~18.04
2022-08-17 16:10:22 install libx32atomic1:amd64 <none> 8.4.0-1ubuntu1~18.04
2022-08-17 16:10:22 install lib32asan4:amd64 <none> 7.5.0-3ubuntu1~18.04
2022-08-17 16:10:22 install libx32asan4:amd64 <none> 7.5.0-3ubuntu1~18.04
2022-08-17 16:10:22 install lib32ubsan0:amd64 <none> 7.5.0-3ubuntu1~18.04
2022-08-17 16:10:22 install libx32stdc++6:amd64 <none> 8.4.0-1ubuntu1~18.04
2022-08-17 16:10:22 install libx32ubsan0:amd64 <none> 7.5.0-3ubuntu1~18.04
2022-08-17 16:10:22 install lib32cilkrts5:amd64 <none> 7.5.0-3ubuntu1~18.04
2022-08-17 16:10:22 install libx32cilkrts5:amd64 <none> 7.5.0-3ubuntu1~18.04
2022-08-17 16:10:22 install lib32mpx2:amd64 <none> 8.4.0-1ubuntu1~18.04
2022-08-17 16:10:22 install lib32quadmath0:amd64 <none> 8.4.0-1ubuntu1~18.04
2022-08-17 16:10:22 install libx32quadmath0:amd64 <none> 8.4.0-1ubuntu1~18.04
2022-08-17 16:10:22 install lib32gcc-7-dev:amd64 <none> 7.5.0-3ubuntu1~18.04
2022-08-17 16:10:22 install libx32gcc-7-dev:amd64 <none> 7.5.0-3ubuntu1~18.04
2022-08-17 16:10:22 install gcc-7-multilib:amd64 <none> 7.5.0-3ubuntu1~18.04
2022-08-17 16:10:23 install gcc-multilib:amd64 <none> 4:7.4.0-1ubuntu2.3
2022-08-17 16:32:30 install libpng12-0-udeb:amd64 <none> 1.2.50-1ubuntu2.14.04.3
2022-08-17 16:39:07 install libpng12-0-udeb:amd64 <none> 1.2.50-1ubuntu2.14.04.3
2022-08-17 16:42:55 install zlib1g-udeb:amd64 <none> 1:1.2.8.dfsg-1ubuntu1
2022-08-17 16:47:55 install libpng12-0-udeb:amd64 <none> 1.2.50-1ubuntu2.14.04.3
2022-08-17 16:53:54 install libpng12-0:amd64 <none> 1.2.50-1ubuntu2.14.04.3
2022-08-17 18:05:41 install gcc-8-base:i386 <none> 8.4.0-1ubuntu1~18.04
2022-08-17 18:05:41 install libgcc1:i386 <none> 1:8.4.0-1ubuntu1~18.04
2022-08-17 18:05:41 install libc6:i386 <none> 2.27-3ubuntu1.6
2022-08-17 18:05:41 install libbz2-1.0:i386 <none> 1.0.6-8.1ubuntu0.2
2022-08-17 18:06:28 install libtinfo5:i386 <none> 6.1-1ubuntu1.18.04
2022-08-17 18:06:28 install libncurses5:i386 <none> 6.1-1ubuntu1.18.04
2022-08-17 18:06:28 install libgpm2:i386 <none> 1.20.7-5
2022-08-17 18:07:18 install libxau6:i386 <none> 1:1.0.8-1ubuntu1
2022-08-17 18:07:18 install libbsd0:i386 <none> 0.8.7-1ubuntu0.1
2022-08-17 18:07:18 install libxdmcp6:i386 <none> 1:1.1.2-3
2022-08-17 18:07:18 install libxcb1:i386 <none> 1.13-2~ubuntu18.04
2022-08-17 18:07:19 install libx11-6:i386 <none> 2:1.6.4-3ubuntu0.5
2022-08-17 18:07:19 install libxext6:i386 <none> 2:1.3.3-1
2022-08-17 18:07:19 install libxtst6:i386 <none> 2:1.2.3-1
2022-08-17 18:07:40 install libexpat1:i386 <none> 2.2.5-3ubuntu0.7
2022-08-17 18:07:40 install zlib1g:i386 <none> 1:1.2.11.dfsg-0ubuntu2.1
2022-08-17 18:07:40 install libpng16-16:i386 <none> 1.6.34-1ubuntu0.18.04.2
2022-08-17 18:07:40 install libfreetype6:i386 <none> 2.8.1-2ubuntu2.2
2022-08-17 18:07:40 install libfontconfig1:i386 <none> 2.12.6-0ubuntu2
2022-08-17 18:07:40 install libxrender1:i386 <none> 1:0.9.10-1
2022-08-17 18:07:40 install libxft2:i386 <none> 2.3.2-1
2022-08-17 18:08:02 install libstdc++6:i386 <none> 8.4.0-1ubuntu1~18.04
2022-08-18 12:25:05 install m4:amd64 <none> 1.4.18-1
2022-08-18 12:25:05 install flex:amd64 <none> 2.6.4-6
2022-08-18 12:25:06 install libbison-dev:amd64 <none> 2:3.0.4.dfsg-1build1
2022-08-18 12:25:06 install bison:amd64 <none> 2:3.0.4.dfsg-1build1
2022-08-18 12:25:06 install libelf-dev:amd64 <none> 0.170-0.4ubuntu0.1
2022-08-18 12:25:06 install libfl2:amd64 <none> 2.6.4-6
2022-08-18 12:25:06 install libfl-dev:amd64 <none> 2.6.4-6
2022-08-18 13:46:30 install hwdata:all <none> 0.290-1ubuntu0.18.04.1
2022-08-18 13:46:30 install linux-tools-common:all <none> 4.15.0-192.203
2022-08-18 13:46:30 install linux-tools-4.15.0-192:amd64 <none> 4.15.0-192.203
2022-08-18 13:46:30 install linux-tools-4.15.0-192-generic:amd64 <none> 4.15.0-192.203
2022-08-18 13:46:30 install linux-tools-virtual:amd64 <none> 4.15.0.192.177
2022-08-18 13:58:11 install linux-hwe-5.4-tools-common:all <none> 5.4.0-125.141~18.04.1
2022-08-18 13:58:11 install linux-hwe-5.4-tools-5.4.0-77:amd64 <none> 5.4.0-77.86~18.04.1
2022-08-18 13:58:11 install linux-tools-5.4.0-77-generic:amd64 <none> 5.4.0-77.86~18.04.1

View solution in original post

0 Kudos
14 Replies
Rainwang
New Contributor II
3,084 Views

i tried the steps again, and error still occurs on the same step

 

make socfpga_arria10_defconfig

with below information:

$ make socfpga_arria10_defconfig
makefile:37: *** missing separator. Stop.

 

is there error in makefile? how to fix it?

thank you for the support.

0 Kudos
Rainwang
New Contributor II
2,814 Views

hi, 

today i tired the stpes on SoCEDS and ARM Development Studio | Documentation | RocketBoards.org, and the u-boot can also be made successfully. so i believe the lack of dependency package is the root cause.

 

the readers who met similar issues can refer to my package list in previous reply.

 

thank you for the strong support!

0 Kudos
JingyangTeh
Employee
3,075 Views

Hi Rainwang

 

I see that you did not run the script "~/intelFPGA_pro/20.1/embedded/embedded_command_shell.sh".

Could you try running the embedded_command_shell script after the git check out.

 

After running the script, you would see something like below:

 

2022-07-25_14h55_13.png

 

Regards

Jingyang, Teh

 

0 Kudos
Rainwang
New Contributor II
3,062 Views

You know I run the tool chain on windows10 platform, not linux.

and i found under my installation path C:\intelFPGA_pro\20.1\embedded, there are 2 files, one is Embedded_Command_Shell.bat, which can be excecuted by clicking Start menu > Intel FPGA 20.1 Pro Edition > SoC EDS Command Shell. the other is embedded_command_shell.sh, i open it by double clike on it.

i also noticed the Embedded_Command_Shell.bat seems base on cygwin, and mbedded_command_shell.sh bases on MINGW, so the 2 shall be used in different scenario as the toolchain?

per your reply, i need to run the embedded_command_shell.sh,and then i follow the instructions step by step, but still similar error occurs on the same step.  all the screen are copied into the attached file for your reference.

still need your support for this, thanks!

0 Kudos
Rainwang
New Contributor II
3,039 Views

i noticed the instruction metioned that the u-boot can only be built on linux, so I tried on ubantu18.04, below are the logs, still something wrong when I excecuted the "make" command.

pls help to check and give me comments, thank you very much.

========================================================================

chunyuwang@GB1LL2J3E:/mnt/c$ ./intelFPGA_pro/20.1/embedded/embedded_command_shell.sh
/mnt/c/intelFPGA_pro/20.1/embedded/env.sh: line 203: /mnt/c/intelFPGA_pro/20.1/embedded/host_tools/altera/ds5_link/soceds_config: No such file or directory
WARNING: DS-5 install not detected. SoC EDS may not function correctly without a DS-5 install.
------------------------------------------------
Intel FPGA Embedded Command Shell

Version 20.1 [Build 177]
------------------------------------------------
chunyuwang@GB1LL2J3E:/mnt/c$ cd $SOCEDS_DEST_ROOT/examples/hardware/a10_soc_devkit_ghrd/
chunyuwang@GB1LL2J3E:/mnt/c/intelFPGA_pro/20.1/embedded/examples/hardware/a10_soc_devkit_ghrd$ rm -rf software/bootloader
chunyuwang@GB1LL2J3E:/mnt/c/intelFPGA_pro/20.1/embedded/examples/hardware/a10_soc_devkit_ghrd$ mkdir -p software/bootloader
chunyuwang@GB1LL2J3E:/mnt/c/intelFPGA_pro/20.1/embedded/examples/hardware/a10_soc_devkit_ghrd$ cd software/bootloader
chunyuwang@GB1LL2J3E:/mnt/c/intelFPGA_pro/20.1/embedded/examples/hardware/a10_soc_devkit_ghrd/software/bootloader$ export https_proxy=3.87.248.1:88
chunyuwang@GB1LL2J3E:/mnt/c/intelFPGA_pro/20.1/embedded/examples/hardware/a10_soc_devkit_ghrd/software/bootloader$ git clone https://github.com/altera-opensource/u-boot-socfpga
Cloning into 'u-boot-socfpga'...
remote: Enumerating objects: 860036, done.
remote: Counting objects: 100% (58086/58086), done.
remote: Compressing objects: 100% (11426/11426), done.
remote: Total 860036 (delta 46206), reused 58081 (delta 46205), pack-reused 801950
Receiving objects: 100% (860036/860036), 206.09 MiB | 227.00 KiB/s, done.
Resolving deltas: 100% (706460/706460), done.
Checking out files: 100% (17968/17968), done.
chunyuwang@GB1LL2J3E:/mnt/c/intelFPGA_pro/20.1/embedded/examples/hardware/a10_soc_devkit_ghrd/software/bootloader$ cd u-boot-socfpga
chunyuwang@GB1LL2J3E:/mnt/c/intelFPGA_pro/20.1/embedded/examples/hardware/a10_soc_devkit_ghrd/software/bootloader/u-boot-socfpga$ git checkout -b test -t origin/socfpga_v2020.04
Checking out files: 100% (13189/13189), done.
Branch 'test' set up to track remote branch 'socfpga_v2020.04' from 'origin'.
Switched to a new branch 'test'
chunyuwang@GB1LL2J3E:/mnt/c/intelFPGA_pro/20.1/embedded/examples/hardware/a10_soc_devkit_ghrd/software/bootloader/u-boot-socfpga$ ./arch/arm/mach-socfpga/qts-filter-a10.sh \
> ../../../hps_isw_handoff/hps.xml \
> arch/arm/dts/socfpga_arria10_socdk_sdmmc_handoff.h
chunyuwang@GB1LL2J3E:/mnt/c/intelFPGA_pro/20.1/embedded/examples/hardware/a10_soc_devkit_ghrd/software/bootloader/u-boot-socfpga$ export CROSS_COMPILE=arm-eabi-
chunyuwang@GB1LL2J3E:/mnt/c/intelFPGA_pro/20.1/embedded/examples/hardware/a10_soc_devkit_ghrd/software/bootloader/u-boot-socfpga$ make socfpga_arria10_defconfig
HOSTCC scripts/basic/fixdep
HOSTCC scripts/kconfig/conf.o
YACC scripts/kconfig/zconf.tab.c
/bin/sh: 1: bison: not found
scripts/Makefile.lib:226: recipe for target 'scripts/kconfig/zconf.tab.c' failed
make[1]: *** [scripts/kconfig/zconf.tab.c] Error 127
Makefile:539: recipe for target 'socfpga_arria10_defconfig' failed
make: *** [socfpga_arria10_defconfig] Error 2

0 Kudos
JingyangTeh
Employee
3,017 Views

Hi Rainwang


I managed to reproduced the error that you have encountered.

Please do give me sometime to look into this.

I will get back to you as soon as possible.


Regards

Jingyang, Teh


0 Kudos
JingyangTeh
Employee
2,984 Views

Hi Rainwang


Could you try changing the steps for building the uboot to this:



wget https://developer.arm.com/-/media/Files/downloads/gnu/11.2-2022.02/binrel/gcc-arm-11.2-2022.02-x86_64-arm-none-linux-gnueabihf.tar.xz

tar xf gcc-arm-11.2-2022.02-x86_64-arm-none-linux-gnueabihf.tar.xz

rm gcc-arm-11.2-2022.02-x86_64-arm-none-linux-gnueabihf.tar.xz

export PATH=`pwd`/gcc-arm-11.2-2022.02-x86_64-arm-none-linux-gnueabihf/bin:$PATH


# Generate U-Boot device tree

cd $SOCEDS_DEST_ROOT/examples/hardware/a10_soc_devkit_ghrd/

rm -rf software/bootloader

mkdir -p software/bootloader

cd software/bootloader


# Get the U-Boot sourece code

git clone https://github.com/altera-opensource/u-boot-socfpga

cd u-boot-socfpga

git checkout -b test -t origin/socfpga_v2020.04


# Generate DTS include file based on the handoff file

./arch/arm/mach-socfpga/qts-filter-a10.sh \

../../../hps_isw_handoff/hps.xml \

arch/arm/dts/socfpga_arria10_socdk_sdmmc_handoff.h


# Build U-Boot

export CROSS_COMPILE=arm-none-linux-gnueabihf-

make socfpga_arria10_defconfig

make -j 24



Regards

Jingyang, Teh



0 Kudos
Rainwang
New Contributor II
2,871 Views

hi, jingyang, 

I tested the steps on my laptop, and below are my feedback.

 

1.  when i excecute the 1 step:

wget https://developer.arm.com/-/media/Files/downloads/gnu/11.2-2022.02/binrel/gcc-arm-11.2-2022.02-x86_64-arm-none-linux-gnueabihf.tar.xz

error message showed that the certificate issue. so i work around it by downloading the package on windows10 and then put it into a folder.

----------------------------------------------------------------

$ wget https://developer.arm.com/-/media/Files/downloads/gnu/11.2-2022.02/binrel/gcc-arm-11.2-2022.02-x86_64-arm-none-linux-gnueabihf.tar.xz
--2022-08-17 09:59:39-- https://developer.arm.com/-/media/Files/downloads/gnu/11.2-2022.02/binrel/gcc-arm-11.2-2022.02-x86_64-arm-none-linux-gnueabihf.tar.xz
Connecting to XXXXXXXX :88... connected.
ERROR: cannot verify developer.arm.com's certificate, issued by ‘C=US,ST=CT,L=Fairfield,OU=GE Corporate IT,O=General Electric Company,CN=GE External Issuing CA 202208162100’:
Unable to locally verify the issuer's authority.
To connect to developer.arm.com insecurely, use `--no-check-certificate'.

------------------------------------------------------------

2. on the SOPC command shell,  i extract the package and also excecuted the rest steps, most run smooth except the make command.

below are the screen i copied. there are some chinese in the log which may caused by my OS version, but it is unimportant because these steps are excecuted successfully.

 

so still need you help to check the problem, thank you in advance.

--------------------------------------------------------------

305019592@GB1LL2J3E /cygdrive/c/users/305019592/downloads
$ tar xf gcc-arm-11.2-2022.02-x86_64-arm-none-linux-gnueabihf.tar.xz

305019592@GB1LL2J3E /cygdrive/c/users/305019592/downloads
$ export PATH=`pwd`/gcc-arm-11.2-2022.02-x86_64-arm-none-linux-gnueabihf/bin:$PATH

305019592@GB1LL2J3E /cygdrive/c/users/305019592/downloads
$ cd $SOCEDS_DEST_ROOT/examples/hardware/a10_soc_devkit_ghrd/

305019592@GB1LL2J3E /cygdrive/c/intelFPGA_pro/20.1/embedded/examples/hardware/a10_soc_devkit_ghrd
$ rm -rf software/bootloader

305019592@GB1LL2J3E /cygdrive/c/intelFPGA_pro/20.1/embedded/examples/hardware/a10_soc_devkit_ghrd
$ mkdir -p software/bootloader

305019592@GB1LL2J3E /cygdrive/c/intelFPGA_pro/20.1/embedded/examples/hardware/a10_soc_devkit_ghrd
$ cd software/bootloader

305019592@GB1LL2J3E /cygdrive/c/intelFPGA_pro/20.1/embedded/examples/hardware/a10_soc_devkit_ghrd/software/bootloader
$ git clone https://github.com/altera-opensource/u-boot-socfpga
正克隆到 'u-boot-socfpga'...
remote: Enumerating objects: 860053, done.
remote: Counting objects: 100% (58103/58103), done.
remote: Compressing objects: 100% (11431/11431), done.
remote: Total 860053 (delta 46220), reused 58095 (delta 46217), pack-reused 801950
接收对象中: 100% (860053/860053), 206.09 MiB | 237.00 KiB/s, 完成.
处理 delta 中: 100% (706474/706474), 完成.
正在更新文件: 100% (17968/17968), 完成.

305019592@GB1LL2J3E /cygdrive/c/intelFPGA_pro/20.1/embedded/examples/hardware/a10_soc_devkit_ghrd/software/bootloader
$ cd u-boot-socfpga

305019592@GB1LL2J3E /cygdrive/c/intelFPGA_pro/20.1/embedded/examples/hardware/a10_soc_devkit_ghrd/software/bootloader/u-boot-socfpga
$ git checkout -b test -t origin/socfpga_v2020.04
正在更新文件: 100% (13189/13189), 完成.
分支 'test' 设置为跟踪 'origin/socfpga_v2020.04'。
切换到一个新分支 'test'

305019592@GB1LL2J3E /cygdrive/c/intelFPGA_pro/20.1/embedded/examples/hardware/a10_soc_devkit_ghrd/software/bootloader/u-boot-socfpga
$ ./arch/arm/mach-socfpga/qts-filter-a10.sh \
> ../../../hps_isw_handoff/hps.xml \
> arch/arm/dts/socfpga_arria10_socdk_sdmmc_handoff.h

305019592@GB1LL2J3E /cygdrive/c/intelFPGA_pro/20.1/embedded/examples/hardware/a10_soc_devkit_ghrd/software/bootloader/u-boot-socfpga
$ export CROSS_COMPILE=arm-none-linux-gnueabihf-

305019592@GB1LL2J3E /cygdrive/c/intelFPGA_pro/20.1/embedded/examples/hardware/a10_soc_devkit_ghrd/software/bootloader/u-boot-socfpga
$ make socfpga_arria10_defconfig
makefile:37: *** missing separator. Stop.

0 Kudos
JingyangTeh
Employee
2,950 Views

Hi Rainwang


Any update on this case?

Have you tried the modified steps suggested?


Regards

Jingyang, Teh


0 Kudos
JingyangTeh
Employee
2,919 Views

Hi Rainwang


Since there are no feedback for this thread, I shall set this thread to close pending. If you still need further assistance, you are welcome reopen this thread within 20days or open a new thread, someone will be right with you.


If you happened to close this thread you might receive a survey.  If you think you would rank your support experience less than 10 out of 10, please allow me to correct it before closing or if the problem can’t be corrected, please let me know the cause so that I may improve your future service experience.


Regards

Jingyang, Teh


0 Kudos
Rainwang
New Contributor II
2,893 Views

hi, jingyang, 

i am sorry for my delay response because i was on vacation these days and just come back to office today, i will check your proposal and give my result ASAP.

 

very appriciated.

0 Kudos
Rainwang
New Contributor II
2,851 Views

it seemed work today.

in fact , i was looking for the solution to support the usb blaster under WSL2, what i did is as below:

1. My platform: WSL2 + ubuntu 18.04 on windows 10

2. to support USB blaster on WSL2, i upgraded the linux kernel from 5.10.16.3 to 5.10.60.1.

3. checked the specification Intel® FPGA Software Installation and Licensing, found some dependencies need to be installed.

from /var/log/dpkg.log, i upgraded below packages, not sure which one is root cause

at last, the usb blaster still can't work on ubuntu, but i found the u-boot now can be made successfully. 

---------------------------------------------------------------------------------------

2022-08-17 14:57:23 install liblzma-dev:amd64 <none> 5.2.2-1.3ubuntu0.1
2022-08-17 15:27:33 install lib32tinfo5:amd64 <none> 6.1-1ubuntu1.18.04
2022-08-17 15:27:33 install lib32ncurses5:amd64 <none> 6.1-1ubuntu1.18.04
2022-08-17 15:42:05 install zlib1g-dev:amd64 <none> 1:1.2.11.dfsg-0ubuntu2.1
2022-08-17 15:57:17 install libtinfo-dev:amd64 <none> 6.1-1ubuntu1.18.04
2022-08-17 15:57:17 install libncurses5-dev:amd64 <none> 6.1-1ubuntu1.18.04
2022-08-17 15:57:17 install u-boot-tools:amd64 <none> 2020.10+dfsg-1ubuntu0~18.04.2
2022-08-17 15:57:17 install device-tree-compiler:amd64 <none> 1.4.5-3
2022-08-17 15:57:17 install libattr1-dev:amd64 <none> 1:2.4.47-2build1
2022-08-17 15:57:17 install libacl1-dev:amd64 <none> 2.2.52-3build1
2022-08-17 15:57:17 install uuid-dev:amd64 <none> 2.31.1-0.4ubuntu3.7
2022-08-17 16:06:50 install libdouble-conversion1:amd64 <none> 2.0.1-4ubuntu1
2022-08-17 16:06:50 install libqt5core5a:amd64 <none> 5.9.5+dfsg-0ubuntu2.6
2022-08-17 16:06:50 install libqt5dbus5:amd64 <none> 5.9.5+dfsg-0ubuntu2.6
2022-08-17 16:06:50 install libqt5network5:amd64 <none> 5.9.5+dfsg-0ubuntu2.6
2022-08-17 16:06:51 install libqt5qml5:amd64 <none> 5.9.5-0ubuntu1.1
2022-08-17 16:06:51 install qttranslations5-l10n:all <none> 5.9.5-0ubuntu1
2022-08-17 16:10:21 install libc6-dev-i386:amd64 <none> 2.27-3ubuntu1.6
2022-08-17 16:10:21 install libc6-x32:amd64 <none> 2.27-3ubuntu1.6
2022-08-17 16:10:21 install libc6-dev-x32:amd64 <none> 2.27-3ubuntu1.6
2022-08-17 16:10:22 install libx32gcc1:amd64 <none> 1:8.4.0-1ubuntu1~18.04
2022-08-17 16:10:22 install lib32gomp1:amd64 <none> 8.4.0-1ubuntu1~18.04
2022-08-17 16:10:22 install libx32gomp1:amd64 <none> 8.4.0-1ubuntu1~18.04
2022-08-17 16:10:22 install lib32itm1:amd64 <none> 8.4.0-1ubuntu1~18.04
2022-08-17 16:10:22 install libx32itm1:amd64 <none> 8.4.0-1ubuntu1~18.04
2022-08-17 16:10:22 install lib32atomic1:amd64 <none> 8.4.0-1ubuntu1~18.04
2022-08-17 16:10:22 install libx32atomic1:amd64 <none> 8.4.0-1ubuntu1~18.04
2022-08-17 16:10:22 install lib32asan4:amd64 <none> 7.5.0-3ubuntu1~18.04
2022-08-17 16:10:22 install libx32asan4:amd64 <none> 7.5.0-3ubuntu1~18.04
2022-08-17 16:10:22 install lib32ubsan0:amd64 <none> 7.5.0-3ubuntu1~18.04
2022-08-17 16:10:22 install libx32stdc++6:amd64 <none> 8.4.0-1ubuntu1~18.04
2022-08-17 16:10:22 install libx32ubsan0:amd64 <none> 7.5.0-3ubuntu1~18.04
2022-08-17 16:10:22 install lib32cilkrts5:amd64 <none> 7.5.0-3ubuntu1~18.04
2022-08-17 16:10:22 install libx32cilkrts5:amd64 <none> 7.5.0-3ubuntu1~18.04
2022-08-17 16:10:22 install lib32mpx2:amd64 <none> 8.4.0-1ubuntu1~18.04
2022-08-17 16:10:22 install lib32quadmath0:amd64 <none> 8.4.0-1ubuntu1~18.04
2022-08-17 16:10:22 install libx32quadmath0:amd64 <none> 8.4.0-1ubuntu1~18.04
2022-08-17 16:10:22 install lib32gcc-7-dev:amd64 <none> 7.5.0-3ubuntu1~18.04
2022-08-17 16:10:22 install libx32gcc-7-dev:amd64 <none> 7.5.0-3ubuntu1~18.04
2022-08-17 16:10:22 install gcc-7-multilib:amd64 <none> 7.5.0-3ubuntu1~18.04
2022-08-17 16:10:23 install gcc-multilib:amd64 <none> 4:7.4.0-1ubuntu2.3
2022-08-17 16:32:30 install libpng12-0-udeb:amd64 <none> 1.2.50-1ubuntu2.14.04.3
2022-08-17 16:39:07 install libpng12-0-udeb:amd64 <none> 1.2.50-1ubuntu2.14.04.3
2022-08-17 16:42:55 install zlib1g-udeb:amd64 <none> 1:1.2.8.dfsg-1ubuntu1
2022-08-17 16:47:55 install libpng12-0-udeb:amd64 <none> 1.2.50-1ubuntu2.14.04.3
2022-08-17 16:53:54 install libpng12-0:amd64 <none> 1.2.50-1ubuntu2.14.04.3
2022-08-17 18:05:41 install gcc-8-base:i386 <none> 8.4.0-1ubuntu1~18.04
2022-08-17 18:05:41 install libgcc1:i386 <none> 1:8.4.0-1ubuntu1~18.04
2022-08-17 18:05:41 install libc6:i386 <none> 2.27-3ubuntu1.6
2022-08-17 18:05:41 install libbz2-1.0:i386 <none> 1.0.6-8.1ubuntu0.2
2022-08-17 18:06:28 install libtinfo5:i386 <none> 6.1-1ubuntu1.18.04
2022-08-17 18:06:28 install libncurses5:i386 <none> 6.1-1ubuntu1.18.04
2022-08-17 18:06:28 install libgpm2:i386 <none> 1.20.7-5
2022-08-17 18:07:18 install libxau6:i386 <none> 1:1.0.8-1ubuntu1
2022-08-17 18:07:18 install libbsd0:i386 <none> 0.8.7-1ubuntu0.1
2022-08-17 18:07:18 install libxdmcp6:i386 <none> 1:1.1.2-3
2022-08-17 18:07:18 install libxcb1:i386 <none> 1.13-2~ubuntu18.04
2022-08-17 18:07:19 install libx11-6:i386 <none> 2:1.6.4-3ubuntu0.5
2022-08-17 18:07:19 install libxext6:i386 <none> 2:1.3.3-1
2022-08-17 18:07:19 install libxtst6:i386 <none> 2:1.2.3-1
2022-08-17 18:07:40 install libexpat1:i386 <none> 2.2.5-3ubuntu0.7
2022-08-17 18:07:40 install zlib1g:i386 <none> 1:1.2.11.dfsg-0ubuntu2.1
2022-08-17 18:07:40 install libpng16-16:i386 <none> 1.6.34-1ubuntu0.18.04.2
2022-08-17 18:07:40 install libfreetype6:i386 <none> 2.8.1-2ubuntu2.2
2022-08-17 18:07:40 install libfontconfig1:i386 <none> 2.12.6-0ubuntu2
2022-08-17 18:07:40 install libxrender1:i386 <none> 1:0.9.10-1
2022-08-17 18:07:40 install libxft2:i386 <none> 2.3.2-1
2022-08-17 18:08:02 install libstdc++6:i386 <none> 8.4.0-1ubuntu1~18.04
2022-08-18 12:25:05 install m4:amd64 <none> 1.4.18-1
2022-08-18 12:25:05 install flex:amd64 <none> 2.6.4-6
2022-08-18 12:25:06 install libbison-dev:amd64 <none> 2:3.0.4.dfsg-1build1
2022-08-18 12:25:06 install bison:amd64 <none> 2:3.0.4.dfsg-1build1
2022-08-18 12:25:06 install libelf-dev:amd64 <none> 0.170-0.4ubuntu0.1
2022-08-18 12:25:06 install libfl2:amd64 <none> 2.6.4-6
2022-08-18 12:25:06 install libfl-dev:amd64 <none> 2.6.4-6
2022-08-18 13:46:30 install hwdata:all <none> 0.290-1ubuntu0.18.04.1
2022-08-18 13:46:30 install linux-tools-common:all <none> 4.15.0-192.203
2022-08-18 13:46:30 install linux-tools-4.15.0-192:amd64 <none> 4.15.0-192.203
2022-08-18 13:46:30 install linux-tools-4.15.0-192-generic:amd64 <none> 4.15.0-192.203
2022-08-18 13:46:30 install linux-tools-virtual:amd64 <none> 4.15.0.192.177
2022-08-18 13:58:11 install linux-hwe-5.4-tools-common:all <none> 5.4.0-125.141~18.04.1
2022-08-18 13:58:11 install linux-hwe-5.4-tools-5.4.0-77:amd64 <none> 5.4.0-77.86~18.04.1
2022-08-18 13:58:11 install linux-tools-5.4.0-77-generic:amd64 <none> 5.4.0-77.86~18.04.1

0 Kudos
JingyangTeh
Employee
2,847 Views

Hi Rainwang


Is it possible if you could share us the defconfig file that you are currently using?

I could not reproduce the error that you are looking at.


If it is possible is it possible if you could follow the steps in the link below to build the u-boot for A10?

https://www.rocketboards.org/foswiki/Documentation/BuildingBootloaderCycloneVAndArria10#Arria_10_SoC_45_Boot_from_SD_Card


Please try out the steps for the "Prerequisite, Arria 10 SoC - Boot from SD Card A.Setup and Arria 10 SoC - Boot from SD Card B.Build U-Boot"

Instead of getting the GHRD from the example folder we will be getting the latest GHRD from the web.


Regards

Jingyang, Teh



0 Kudos
JingyangTeh
Employee
2,793 Views

Hi Rainwang


Since this thread been resolve, I shall set this thread to close pending. If you still need further assistance, you are welcome reopen this thread within 20days or open a new thread, some one will be right with you.


If you happened to close this thread you might receive a survey.  If you think you would rank your support experience less than 10 out of 10, please allow me to correct it before closing or if the problem can’t be corrected, please let me know the cause so that I may improve your future service experience.


Regards

Jingyang, Teh


0 Kudos
Reply