Intel® SoC FPGA Embedded Development Suite
Support for SoC FPGA Software Development, SoC FPGA HPS Architecture, HPS SoC Boot and Configuration, Operating Systems
Announcements
The Intel sign-in experience is changing in February to support enhanced security controls. If you sign in, click here for more information.
349 Discussions

Intel SoC FPGA Embedded Development Suite Version 21.1

GQUIR2
Novice
729 Views


Some weeks ago I downloaded
SoCEDSSetup-21.1.0.842-windows.exe
Now, when selecting version 21.1 the Bowser jumps and shows version 20.1

(SoCEDSSetup-20.1.0.711-windows.exe).
Is Version 21.1 obsolete and has some Bugs?
Kind regards
Gerhard

0 Kudos
10 Replies
krose
Beginner
719 Views

Same problem. Was just coming to the forums to ask the same question.

EBERLAZARE_I_Intel
693 Views

Hi,


Can you share the correct link where you downloaded the 21.1 SoC EDS?


For Quartus version 20.2 and above, you can use 20.1 SoC EDS in below link and select SoC EDS:

https://www.intel.com/content/www/us/en/collections/products/fpga/software/downloads.html?s=Newest


However, SoC EDS Will be using old version of U-boot, so to build and use the latest version of U-boot, you need to refer below for Cyclone V and Arria 10 SoC Devices:

https://rocketboards.org/foswiki/Documentation/BuildingBootloaderCycloneVAndArria10


EBERLAZARE_I_Intel
666 Views

Hi,


Any further update from your side?


GQUIR2
Novice
657 Views

With "SoCEDSSetup-21.1.0.842-windows.exe" I get no access to my Network Drive.

For Network Drive h:

$cd h

bash: cd: h: Too many levels of symbolic links.

I have only access to local HDD Drive of my Computer.

With "SoCEDSSetup-20.1.0.711-windows.exe" I get access to my Network Drive.

For Network Drive h:

$cd h

Quxxxxxch@W4Mxxxx8 /cygdrive/h

 

EBERLAZARE_I_Intel
563 Views

Hi,


Actually we do not release for SOC EDS version 20.3 and above, pro nor standard.


So we would like to know where did you downloaded the 21.1 version.


As of now, we recommend that you stick with 20.1 version for any Quartus version 20.1 and later.


GQUIR2
Novice
555 Views

SoC_EDS_Command_Shell_Problem.PNG

In the past it was possible, see attached Screenshot!

Intel FPGA Download Internet Page has now changed!

EBERLAZARE_I_Intel
536 Views

Hi,


I understand that it may have worked, and as I have suggested previously, for Quartus 20.3 and above, you are to use SoC EDS version 20.1.


And if you could help us know and confirm, that you have downloaded the SoC EDS version 21.1 in the old Intel FPGA download page?


Please use only the SoC EDS version 20.1, as we do not confirm the behavior when using the 21.1 version.


Also, the SoC EDS is using old version of U-boot, and if you would like to use the newer version you would need to refer here:

https://rocketboards.org/foswiki/Documentation/BuildingBootloader


We recommend customer use the latest version of U-boot and the latest flow above.


EBERLAZARE_I_Intel
508 Views

Hi,


Do you have any follow up questions?


EBERLAZARE_I_Intel
500 Views

Hi,


Please refer to below KDB:

https://www.intel.com/content/www/us/en/support/programmable/articles/000086433.html


We do not receive any response from you to the previous question/reply/answer that I have provided. This thread will be transitioned to community support. If you have a new question, feel free to open a new thread to get the support from Intel experts. Otherwise, the community users will continue to help you on this thread. Thank you


Reply