Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Shirren__Conor
Beginner
96 Views

Configuring Sawtooth for PoET SGX

Hi all,

 

I am attempting to configure Sawtooth to use PoET SGX in Ubuntu 16.04 according to the following URL: https://sawtooth.hyperledger.org/docs/core/nightly/1-1/sysadmin_guide/configure_sgx.html

I have reached the point of creating a proposal using the following command:

$ sawset proposal create -k /etc/sawtooth/keys/validator.priv \ sawtooth.consensus.algorithm.name=PoET \ >sawtooth.consensus.algorithm.version=0.1 \ sawtooth.poet.report_public_key_pem="$(cat /etc/sawtooth/ias_rk_pub.pem)" \ >sawtooth.poet.valid_enclave_measurements=$(poet enclave --enclave-module sgx measurement) \ >sawtooth.poet.valid_enclave_basenames=$(poet enclave --enclave-module sgx basename) \ >sawtooth.poet.enclave_module_name=sawtooth_poet_sgx.poet_enclave_sgx.poet_enclave \ -o config.batch

 

The errors I am receiving can be found in the attached screenshots below.

 

 

0 Kudos
0 Replies
Reply