Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Avradip_M_
Beginner
126 Views

SGX Eclipse Plugin Build Failure

I am having a strange issue when trying to build the eclipse plugin. Can you please help.

 

preSetup:
      [ant] Exiting /vagrant/linux-sgx/Linux_SGXEclipsePlugin/build_config/customTargets.xml.
  [antcall] Exiting /vagrant/eclipse/plugins/org.eclipse.pde.build_3.9.100.v20150521-1524/scripts/build.xml.

BUILD FAILED
/vagrant/eclipse/plugins/org.eclipse.pde.build_3.9.100.v20150521-1524/scripts/build.xml:32: The following error occurred while executing this line:
/vagrant/eclipse/plugins/org.eclipse.pde.build_3.9.100.v20150521-1524/scripts/build.xml:48: The following error occurred while executing this line:
/vagrant/linux-sgx/Linux_SGXEclipsePlugin/build_config/customTargets.xml:79: Problem: failed to create task or type eclipse.generateFeature
Cause: The name is undefined.
Action: Check the spelling.
Action: Check that any custom tasks/types have been declared.
Action: Check that any <presetdef>/<macrodef> declarations have taken place.

    at org.apache.tools.ant.UnknownElement.getNotFoundException(UnknownElement.java:499)
    at org.apache.tools.ant.UnknownElement.makeObject(UnknownElement.java:431)
 

 

0 Kudos
4 Replies
Avradip_M_
Beginner
126 Views

The problem has been solved, there was some issue with PDE plugin installation in eclipse. 

marcos_a_
Beginner
126 Views

Hello Avradip,

I am trying to build SGX Plugin as well. Maybe you can help me?

I have downloaded and followed "Intel Software Guard Extensions for Linux OS", version 1.8. I am using CentOS 7.3.

According to "Linux_SGEEclipsePlugin\readme.txt", we must use "Eclipse Mars CDT 4.5.1.xxxxxx" and also "PDE Plugin 3.11.1.xxxxx".

I downloaded Eclipse Mars 1 and installed without any problems. Now, I need to get the PDE Plugin  "PDE Plugin 3.11.1.xxxxx".

My computer does not have access to the network so I need to find a zip file for the "PDE Plugin 3.11.1.xxxxx" in order to install on Eclipse.

  • My question is, do you have or know where I can find a zip file for the "PDE Plugin 3.11.1.xxxxx"?
  • Or maybe do you know where can I find MARS 1 eclipse that contains already the correct version of PDE?

Thanks for your help and time,

Rgds

Marcos

 

 

 

Avradip_M_
Beginner
126 Views

Hi Marcos,

I just installed PDE plug-in 3.11.1v20150904-0345 from eclipse 4.5 update site (http://download.eclipse.org/eclipse/updates/4.5). I am not really sure whether you can get the zip file from there or not.

Avradip

marcos_a_
Beginner
126 Views

Hi Avradip,

Thanks.

I found a solution for my problem, regarding the PDE plugin in zip file from:

http://archive.eclipse.org/eclipse/downloads/drops4/R-4.5.1-201509040015/

Then I had to download:

      org.eclipse.jdt.source-4.5.1.zip 

      org.eclipse.jdt-4.5.1.zip

      org.eclipse.pde.source-4.5.1.zip
      org.eclipse.pde-4.5.1.zip

The reason to download the files instead using the plugin repos done automatically via internet is because my target Linux machine could not have a internet connection. So, all that installation had to be done 'offline'. The zip files were copied from another machine that had access to the internet and then transferred to my Linux box.

After that, I could install the PDE by loading those zip files.

In Eclipse, I selected "Help-->Install New Software". You need also to make sure you have UNSELECTED "Group Items by Category".

Then selected "Add button" and "Add Repository" screen shows up. On this new screen, I selected "Archive" and then browsed to the directory where I had the plugins in zip format.

I had to install the plugins on this order:

      org.eclipse.jdt.source-4.5.1.zip

      org.eclipse.jdt-4.5.1.zip

      org.eclipse.pde.source-4.5.1.zip

      org.eclipse.pde-4.5.1.zip

Thanks

Rgds

Marcos

 

 



 

 

Reply