Intel® Software Guard Extensions (Intel® SGX)
Use hardware-based isolation and memory encryption to provide more code protection in your solutions.

installing SGX driver for ubuntu.

Shredha_K_
Novice
29,764 Views

Hi,

I got this error when I tried to install the SGX driver for ubuntu 14.04.  modprobe: ERROR: could not insert 'isgx': Required key not available. 

 I followed the installation guide on the official site https://download.01.org/intel-sgx/linux-1.7/docs/Intel_SGX_SDK_Installation_Guide_Linux_1.7_Open_Sou...:

How can I solve this.

Thanks in advance.

0 Kudos
1 Solution
Surenthar_S_Intel
29,764 Views

Hi,

You may want to disable secure boot in BIOS settings and enable SGX . 

Under “Security” Tab,

   i. Under “Intel® SGX”

       1. Set Intel ® SGX Control to “Enabled”

   ii. Under “Secure Boot”

       1. Set Secure Boot to “Disabled”

-Surenthar

View solution in original post

4 Replies
Saeid_M_
Beginner
29,764 Views

Hi Shredha,

I got the same error when I tried to install Linux kernel driver on my Ubuntu OS which was on a VM-Ware virtual machine and with a None-SGX enabled computer. Then, I tried it again with My SGX-enabled machine and a real Linux(Not VM), and everything was ok. Based on my observation I would conclude that either your CPU is not SGX enabled CPU or you did not enable SGX functionality in your computer BIOS.

Possible solutions:

1-Make sure you have a Skylake CPU which is 6th generation CPU. 

2-Make sure you have enabled SGX support functionality in your computer BIOS.

Best Regards,

Saeid

Surenthar_S_Intel
29,765 Views

Hi,

You may want to disable secure boot in BIOS settings and enable SGX . 

Under “Security” Tab,

   i. Under “Intel® SGX”

       1. Set Intel ® SGX Control to “Enabled”

   ii. Under “Secure Boot”

       1. Set Secure Boot to “Disabled”

-Surenthar

Shredha_K_
Novice
29,764 Views

Thank you for the comments. It really helped

Garg__Shivam
Beginner
29,764 Views

facing the below issue when installing the SGX driver on Centos 7.4.

[root@local_host POC1]# sudo ./sgx_linux_x64_driver_1.6.100.32783.bin

Unpacking Intel SGX Driver ... done.
Verifying the integrity of the install package ... done.
Installing Intel SGX Driver ...
/tmp/sgx-driver-AjAGqc ~/POC1
install -d /opt/intel/sgxdriver/package
install -d /opt/intel/sgxdriver/scripts
install package/* /opt/intel/sgxdriver/package
install scripts/* /opt/intel/sgxdriver/scripts
~/POC1
/opt/intel/sgxdriver/package ~/POC1
make -C /lib/modules/3.10.0-327.36.1.el7.x86_64/build SUBDIRS=/opt/intel/sgxdriver/package CFLAGS_MODULE="-DDEBUG -g -O0" modules
make: *** /lib/modules/3.10.0-327.36.1.el7.x86_64/build: No such file or directory.  Stop.
make: *** [default] Error 2
/bin/sed: can't read /etc/modules: No such file or directory
/bin/sed: can't read /etc/modules: No such file or directory
Reply