Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Hamed_h_
Beginner
59 Views

Reservoir Simulator Software

Hi,

Actually, I am a petroleum engineer, I am going to modify one open source reservoir simulator. To compile the original simulator I use the win 7, 32bit, VS 2008, Intel(R) Visual Fortran Compiler Integration  11.1.3470.2008  : There are two solutions: 1: API to build library on HDF5 2: Simulator 

However I can build the API (without error), I can not run it and I face this error ( I am not sure if it is necessary to run it or just building is enough):

 Visual Studio cannot debug because a debug target has not been specified. 

After building the API , The library was created in the  related folder, I started to build in release as well as debug for simulator solution, at that time came up with this error: 

Debugging information for UTCHEM93.exe cannot be found or does not match. Binary was not built with debug information.

please help me to find out the problem to run the exe. file one time and after that start to modify the Fortran source codes because my main area is to focus on some function in the source code.

I have attached the simulator package (source codes and read me file).

Thanks

0 Kudos
5 Replies
Georg_Z_Intel
Employee
59 Views

Hello,

looking at the projects:

  • "kase20", which seems to be the "API" you're referring to, does not have any "program" block. Hence nothing to execute - it's a library.
    You need an application that uses it to execute and debug. Hence, also the project property "Debugging/Command" is empty.
  • "utchem93" is an application and in the properties "Debugging/Command" it properly sets "$(TargetPath)".
    The error you get is because of missing debug information. You need to recompile the application in question with debug options enabled, via project properties:
    • "Fortran/Debugging": Set "Debug Information Format" to value "Full (/debug:full)"
    • "Linker/Debugging": Set "Generate Debug Info" to value "Yes (/DEBUG)"

      If neither of those are set you won't be able to debug easily.
      I see that default is "KaseRelease" - use "KaseDebug" which has set the above options already

Best regards,

Georg Zitzlsberger

 

 

0 Kudos
Hamed_h_
Beginner
59 Views

Greeting Georg,

Your quick answer is highly appreciated. Many thanks.

I have changed the project properties as you mentioned. I faced a new error (in both  KaseDebug or Debug)which I have attached it to this post

Again many thanks for you consideration.

error.bmp

0 Kudos
Georg_Z_Intel
Employee
59 Views

Hello,

this is related to your software (utchem93) and neither to the compiler nor debugger.

Seems your software is reading a file called "HEAD" which is either empty or does not contain the required number of records.

The "forrtl" error is a general I/O error from the Fortran runtime (caused by "READ"). So, "READ" failed to get the data from the input file.

Best regards,

Georg  Zitzlsberger

0 Kudos
Hamed_h_
Beginner
59 Views

Dear Georg,

Thanks for your time consideration. As you mentioned I think the problem occur because of missing input file. However I have a sample of the input file (attached to this comment), I couldn't find the correct path to put it. Only the procedure for running in Linux has been explained  in the readme file.

Again many thanks for your constructive comments.

0 Kudos
Georg_Z_Intel
Employee
59 Views

Hello,

I've build the "Debug" mode and executed it. I get the same error as you.
Reason is as I described before:

..\UTCHEM931-kraken-win\dev\Projects\utchem93\mvs\HEAD is empty (0 Bytes)

The failing READ tries to read 6 ASCII chars which does not work on an empty file.

I don't know utchem93 and suggest to consult the owners of that application on how to operate and configure it.

Best regards,

Georg  Zitzlsberger

0 Kudos