Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
301 Views

Connection problems with a win10 target

Hi,

so I'm using the latest Intel System Studio version on a win10 host and can connect perfectly fine to my target running Linux via DCI. The target gets also listed under "Intel DCI Transports (USB-Based)" in the device manager as it should.

Now if I use windows 10 on the same target the device doesn't show under "Intel DCI Transports (USB-Based)" anymore, but under "Other devices" as an "unknown device" and I can't connect to it anymore via Intel System Studio and get an error message saying "OpenIPC was configured and started successfully but no target was found". 

Can anyone help me fixing this?

Also another question:

is it possible to start the ISD Shell itself without having to always start Intel System Studio? That would save me alot of time. (if I just run isd_cli.exe it crashes)

Thanks in advance!

0 Kudos
8 Replies
Highlighted
289 Views

@Kruemmelmonster :

Yes, we have an option to connect to debug target via CLI:

https://software.intel.com/content/www/us/en/develop/documentation/system-debug-user-guide/top/intel...

In your case, it looks like there's something wrong with the connection itself. You can remove the DCI probe, do a cold reboot of the target and re-connect to the same USB port you connected for the working case (with Linux) and see if the target gets listed correctly under Intel DCI Transports (USB-Based) in Device Manager. If this step is not correctly configured, the further debug steps will fail.

0 Kudos
Highlighted
279 Views

Thanks for the fast anwser.

The CLI option works perfectly, thanks for that!

When it comes to windows though, i still had no luck there. Tried your suggestion multiple times but it still doesn't seem to work. Do I maybe need some special drivers?

0 Kudos
Highlighted
273 Views

@Kruemmelmonster :
Well, the DCI drivers usually come installed as part of ISS itself. Usually, you don't have to install it manually. But since this issue is coming up consistently, I think it may be worthwhile to try uninstalling and reinstalling the DCI driver on the Windows host machine, hook it to the target and see if the device enumerates correctly.

You can find the DCI driver installer file (.msi) inside one of the sub-folders of your ISS installation directory. The name of the driver will be something like --> Setup_x64_Intel_DCI_Driver_XYZ.msi

Please give it a try and let me know if it works.

0 Kudos
Highlighted
257 Views

Thanks again for the answer!

Tried as you said (Unplug -> Uninstall Driver -> Install -> Plug in again) but it still doesn't show.

But I've noticed two other things that might help:

1. When I first plugged in the device again after reinstalling the driver windows gave me a notification that went something like this
"USB Device Not detected try plugging it in again" (After that it showed as "unknown device")

2. Sometimes when I plug the cable in nothing happens. No sound or anything from windows and it also doesn't get listed at all

 

0 Kudos
252 Views

@Kruemmelmonster :

I see.

We can try disabling driver signature and try once. Can you please perform the below steps on the host and see if it works?:

bcdedit /set testsigning on
bcdedit.exe -set loadoptions DDISABLE_INTEGRITY_CHECKS
bcdedit.exe -set TESTSIGNING ON

0 Kudos
Highlighted
241 Views

Tried that but still get the same results

But again, thanks alot for the quick answer!

0 Kudos
Highlighted
239 Views

@Kruemmelmonster :

You're welcome.

I reckon you applied the settings in admin command console, and did a restart before plugging the target?

Also, I am assuming you have configured the BIOS correctly with all the debug settings which you did for the working Linux target?

0 Kudos
Highlighted
234 Views

Yup, applied the settings via admin shell; unplugged; rebooted both devices, plugged in again.

And since I dual boot Linux and Windows on the same machine I reckon that I have all the right bios settings set since it works on Linux. 

0 Kudos